Linetype definitions disappear and can't be imported - BUG?


I just noticed a weird behavior. I was working in a file on some drawings. I had the default linetypes loaded from the very beginning (I am sure about this since while I was sketching I was changing a couple of lines).

I finished the drawing and started sorting out the drawings on different layers. When I wanted to assign a new linetype to the layer I noticed there were none. I tried creating one - didn’t happen. Tried importing - not working - see attached images.

Is this a known Bug? (currently running on 6.10.18311.20531, 11/7/2018)!

3 screenshots showing the “import action”:

and a last image showing the “result” - not really as expected

Hi - this isn’t a known issue, no. Please upgrade to SR12, which is the current version of Rhino 6.
That might not solve the issue, and to get some more insight, please run the Rhino SystemInfo command and post the result here. Thanks.

Hi Wim,

Updating to SR12 has apparently fixed this behavior.


Hi Wim,

I’m on Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb) and the problem persists. Importing linetypes looks like it’s working when actually it isn’t.

Thanks for looking into this again.

Problem persists in Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)

Hi Duncan, could you paste the entire SystemInfo?
Also, could you please describe what you are seeing and doing? It might be necessary to post a few files as well so that we can try to reproduce the issue here.