Line caps in rhino

Good afternoon¡

I am triying to create some 2D plan with rhino, but I dont like how thick lines looks like. Could I make the end of those lines rounded or at least join them? I attached some images, one of rhino and another one of autocad, that makes what I was triying to do

This is the Rhino file

This is what i am triying to achieve, it doesnt have to be rounded, but at least closed i think…

thanks a lot


This has been on the wishlist for a long time but has not been developed yet.

1 Like

Thanks Jhon¡ I think that it is very important cause if not…we should finish the drawings in other softwares that are much worst than rhino¡


Rounded end caps have been implemented in SR7 which will be available on Tuesday as an initial release candidate.

I think this has been tuned up - I think…, if I’m thinking of the right thing… hold on a bit, I’ll look for the bug.
oops. never mind - I say what Steve said.

Hey i found a very stupid solution…if i go to linetypes and i change the pattern insted of 1 to 2 or 3…suddenly the corners became rounded :rofl:

Hey Guys, I’m using Rhino 7 and wanted to know if the end cap issue has been addressed. I’m getting squared off and want rounded. Thanks!

Hi Ian - this is what I see in V7, with PrintDisplay on


I take it that is not what you see?

Please run the SystemInfo command in Rhino and copy/paste the results here.


Hi Pascal,

Thanks for your response. I should have been more specific…the lines on my screen in model space are rounded like in your picture. But when they print they look squared off. It seems the workaround for this is to join the curves which seems like another step that could be solved with printing option.

Hm - that should work as well

Can you run SystemInfo in Rhino and copy/paste the results?


Rhino 7 SR3 2021-2-8 (Rhino 7, 7.3.21039.11201, Git hash:master @ 7bcc02a54515376cb2bd3d05f62d9473ab4bc38c)
License type: Commercial, build 2021-02-08
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA Quadro RTX 3000 with Max-Q Design (NVidia) Memory: 6GB, Driver date: 9-23-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.41
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-23-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Users\ianmc\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.20335.757

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Are you printing to Rhino PDF? I just saw another report about this recently

yes, and just tried with standard pdf option and got the same result

Shot in the dark would be to disable VIsualArq/Tibidabo in Options > Plug-ins page (close and reopen Rhino after) and see if that changes anything .


No luck

Hi Ian -

I’ll create a bug track item for that.
Edit - we have that issue on our list as item RH-50899
Thanks for reporting.

1 Like

Hi Ian - yeah, we see it here too - it works with raster and not with vector printing - I had my settings on raster for some reason when I tested earlier. The developer is ‘on it’.


1 Like

Thanks much!


I am new to this forum so please excuse my lack of understanding of how this works. I clicked on your edit to item RH-50899 and took me to another page where it looks like you noted this issue was resolved. I opened Rhino today and updated to the newest version. I tried printing to PDF again and it appears the end caps are still squared off. Let me know if this is something on my end, or if the fix has not yet made it to the updates, or…Thanks much!