Legacy Space Pilot device in Rhino 6

After installing and then uninstalling of 3DxWare64_BETA_v10-6-5_r3156, followed by a Windows 10 restart, Rhino 6 (Version 6 SR23 (6.23.20055.13111, 24.2.2020 г.) Evaluation) suddenly works with my SpacePilot!!! No 3DxWare driver at all.

The + and - buttons to control the speed of rotation work. The “Fit” button works. The L, R, T and F buttons for Left, Right, Top and Front view, respectively, all work.
However, the 6 function keys of the SpacePilot are pre-assigned by default in the following way and can’t be modified since there is no software to control these changes:

  1. Command history.
  2. Save.
  3. Undo view.
  4. Show object control points.
  5. Rotates the view to Top, but keeps the Perspevtive viewsport label.
  6. Nothing.

There is no way to individually change the speed of the 3d “Cap” in each direction. No sliders for that, since no software. This makes me think that Rhino 6 could natively support older 3d connexion software, as long as someone at McNeal wants to write a code to make a dedicated menu window with sliders and button assign function in a similar fashion like 3DxWare 10.3.0 , for example. It’s the best performing version of 3DxWare for use with SpacePilot.

As for the big dead zone of the new 3d connexion devices, maybe this link will give you a solution:

I still don’t know what you mean… dead in what way?

A dead zone is an area at which the input movement is not registered by the software. Think of it as a way to minimize errors caused by accidental gently touches of the 3d cap of your 3d connexion device. It’s present on the analog sticks of game controllers, too. The problem with the modern 3d connection devices is that their dead zone is so big that it causes problems for those who prefer the higher speed settings.

Huh, mine has zero deadzone… :thinking:

Coming back to this issue… It’s really frustrating to have to choose between my MCAD (runs with driver) and Rhino (runs without driver). Is there a way that I can downgrade my Rhino 6 version to be able to run the 3dconnexion plugin before they stripped support for 10.4.10 drivers?

3dxrhino.rhp (444.2 KB)
Found a solution. McNeel tech support linked me to the Rhino 6.3 install. I installed it, backed up the working 3dxrhino plugin and updated to the latest version of Rhino. Then I replaced the latest (stripped down) plugin with the backup of the previous version and my SpacePilot now works with 10.4.10 and prior drivers with the most recent Rhino release. Attached is the old plugin for anyone looking for it; 3dxconnexion certainly won’t help you acquire it. Just drop it in your …\Rhino 6\Plug-ins\ folder.

I used that approach until Rhino 6.6 by replacing its plug-in with the one of Rhino 6.4, but then Rhino 6.7 introduced some major changes and so it refused to accept the older plug-in anymore when 3DxWare 10.3.0 was installed. I tried your plug-in now, both on Rhino 6 SR25 and the latest SR27, first with 3DxWare 10.3.0, then with 3DxWare 10.4.10, but in either combination it shows a crash warning.

Did you post the correct screen shot? It shows your license is expired. It only shows that when you use the old plugin?

1 Like

Hi Bobi - an expired Rhino doesn’t allow plug-ins to be loaded.

1 Like

Yeah, I use Rhino 6 evaluation that expired last month. Previously it had a Rhino 6.4 plug-in that didn’t worked with my SpacePilot, but at least Rhino started properly. Crashing of the latest Rhino 6 SR27 only happens when I replaced its default plug-in with the one from Rhino 6.3 that was posted above by @jwesthov. :slight_smile: The default plug-in that ships with Rhino 6 SR27 that I downloaded today didn’t cause crashing of Rhino, despite being an evaluation version.

So, after so many years spent in that discussion, is there a way to force the new Rhino 7 to support SpacePilot? Rhino 6.4 worked wonderfully with it… Until Rhino 6.5 arrived and support have been cancelled…
Upon loading Rhino 7 shows the following warning:

The problem is that 3DxWare version 10.5.6 does not support SpacePilot. Rhino 7, on the other hand, does not support older 3DxWare plug-ins that worked flawlessly with SpacePilot, such like 3DxWare version 10.3.0. So, which company is responsible for the lack of software support (or the intentional removal of software support) for SpacePilot and other older 3d connexion devices that previously worked until Rhino 6.4?

The way I see it, if the staff at “McNeel” decides to add a legacy plug-in support for 3DxWare version 10.3.0, that would immediately solve the problem. “3d connexion” removed the support for SpacePilot in their newer plug-ins, so the only hope is to rely on “McNeel”'s kindness to include legacy support.

Hi @Rhino_Bulgaria,

Some information on discontinued 3dConnexion devices.

Since we (McNeeel) do not write the 3dxRhino plug-in, there is no way for us to add support for discontinued devices - sorry.

All we can suggest is contacting 3dConnexion.


– Dale

Hi Dale, thank you for the reply! What if “McNeel” decides to add support for legacy plug-in written by “3d connexion”, such like 3DxWare version 10.3.0? If Rhino 7 is enabled to work with 3DxWare version 10.3.0, then legacy devices such like SpacePilot will work flawlessly, just like they did until Rhino 6.4 a few years ago. :slight_smile:

There was a trick that worked with the initial releases of Rhino 6. Here is a copy of the description that someone wrote a few years ago:

"Note: You can skip steps 1 and 2 if you directly open the plug-ins directory of Rhino 6 (usually C:\Program Files\Rhino 6\Plug-ins).

  1. Open Rhino 6 and go to Options > Plug-ins.

  2. Locate the 3Dconnexion 3D Mouse plug-in and right-click it, then choose Open Containing Folder. Now close Rhino 6.

  3. After opening the folder, delete the original 3dxrhino.rhp and replace it with this one.

Now the 3D mouse plug-in in Rhino 6 will work with the discontinued 3Dconnexion models such like SpacePilot."

Then the problem was that later versions of Rhino 6 (I think it all started with Rhino 6.6) no longer allowed swapping the 3dxrhino.rhp file with an older versions of the same file from Rhino 6.3, ultimately making it impossible to use legacy devices such as SpacePilot.

I swap the plugin for the old one every update (each update replaces the old working plugin with the new one that strips support for the older devices). I’m currently on 6.31 and running the old plugin and my SpacePilot works fine on two different computers. I haven’t tried 7 yet, but it may even work for it too.

Rhino 6.4 worked wonderfully with the old plug-in that was manually replaced. However, somewhere in mid 2018 Rhino 6.6 introduced some unknown changes that no longer allowed swapping the default plug-in with an older version. Later Rhino 6 versions removed the support for 3DxWare version 10.3.0, so that change is on the “McNeel” side.
I already tried to manually swap the plug-in of Rhino 7 and the program will not start after those changes. It simply crashes and shows some warning that there is an error in the plug-in. That’s pity, because early Rhino 6 versions allowed the manual swap.

Wow, I found a solution! Rhino 7 now works with my SpacePilot. Here is what I did to make it happen:

  1. On Windows 10 I already had 3DxWare version 10.3.0 installed.
  2. I opened the following folder: “C:\Program Files\Rhino 7\Plug-ins”.
  3. Then I made a back-up copy of the “3dxrhino.rhp” plug-in and placed it in another folder just in case.
  4. Then I used the following plug-in from Rhino 6.3 and replaced the original Rhino 7 plug-in:
    3dxrhino.rar (130.6 KB)
  5. Then I started Rhino 7 and the 3d connexion plug-in recognized the program as Rhinoceros 5 (SpacePilot has an LCD screen that shows that information).
  6. The SpacePilot required some settings to be made inside Rhino 7, such as “Lock Horizon” etc, just the usual customization that everyone does.

The only thing that didn’t not work at first were the custom macros assigned to the 6 function buttons under the LCD screen of SpacePilot. Other than that, the rest buttons work as expected. However, I also found a fix for that. All the macros must be deleted and made from scratch. Then they work again.

It works for now and I tested it with a restart of the PC. Hopefully that future updates will not break this “hack” with swapping the plug-in with an older version.
Is there a way that “McNeel” could ship future Rhino 7 updates with support for the old plug-in that I uploaded above?


Is there a way for the developers to include that older Rhino 6.3 plug-in along with the Rhino 7 plug-in, and let the user choose whish one to use in Rhino 7 (maybe via some menu setting for supporting legacy/discontinued 3d connexion mice)?

1 Like