3DConnexion settings problem

Maybe try without the driver and configuration software?

I’ve always used without, and even now it works just fine, settings (made in Rhino) stick.

Interesting. Where do you configure the buttons of your 3DConnexion devices?

I don’t know if I can use my wireless 3DConnexion mice without a driver?

Right now I have only a space navigator. I used to have a SpacePilot Pro, but that was taken without permission nor.returned to me. So I don’t recall how I configured it in Rhino.

In Rhino I used it only for navigation with its puck and the default button settings. The settings you can change is through the menu button on the device in an active viewport. You get a popup where you can choose the mode, rotation center, speed and such.

In Blender there is quite extensive configuration possibility (I added much of that long ago), not sure if the plug-in settings in Rhino allow for that ( under Tools > Options)

Rhino at some point moved all the settings to the 3DConnexion driver. It has worked for a long time but now it really got annoying. I have four 3DConnexion devices and I’m using the buttons extensively.

I really don’t want to change the settings every time I open Rhino

I uninstalled the driver to mine today and it works a lot better. At least for now.—-Mark
It worked in V5,V6,V7 and the WIP

1 Like

Maybe if you try this solution with replacing the default “3dxrhino.rhp” plug-in with the one from Rhino 6.3, it will work on you Rhino? Keep in mind that every time you update Rhino 7 with a new Service release, it will replace the “3dxrhino.rhp” plug-in and so if you wish to continue using the older Rhino 6.3 “3dxrhino.rhp” plug-in you will have to replace the default one manually once again. Since I use a discontinued SpacePilot device (intentionally discontinued by “3Dconnexion” so that they could force you buy their new devices) which is no longer supported by the Rhino 7’s default “3dxrhino.rhp” plug-in. That gives me the chance to use my SpacePilot in Rhino 7. :slight_smile:

Fun fact: The “3dxrhino.rhp” plug-in used in Rhino 6.3 was actually a Rhino 5 plug-in, so basically now I use Rhino 7 with a Rhino 5 “3dxrhino.rhp” plug-in. :rofl: This way, the LCD screen of my SpacePilot recognizes Rhino 7 as Rhino 5 instead, so it works as a time machine.

2 Likes

Using the device without the driver is not a solution since I’m also using wireless 3DConnexion mice.

It is a bit weird that we have a popup that says my device is in Object Mode but the 3DConnexion settings say the device is in Camera Target Mode.

As suggested by 3DConnexion support I tried to update the firmware.

No success so far.

Am I the only Rhino + 3DConnexion user to experience this problem?

Every time I open Rhino, the 3DConnexion settings for navigation mode show Camera Target however SpaceMouse command Popup menu shows Object Mode.

Anyone?

My SpacePilot works perfect with Rhino 7, but I have to manually replace the 3d mouse plug-in with an olded plug-in from Rhino 5 every time after I update Rhino, because my device was discontinued in 2013.

My device is still supported so it is a different situation.

It’s annoying

Yes you can. Mine works fine (except recent problems with focus) just with default drivers.

My 3DConnexion mice are wireless.

I’m pretty sure you are talking about a space navigator so not a mouse

@Markus I’d appreciate your help on this issue.

There is an open case at 3Dconnexion technical support but Oliver Seyding unfortunately has not been able to help yet.

AW: [CASE:120086] [DACH] / 3DCX-20210415-0001 / / Siegrist, Martin

I’ve just uninstalled deleted rolled back to driver version 10.6.4 with no success so far.

I still cannot save the settings for the navigation mode “Objekt Modus” through the 3dconnexion menu. Every time I open Rhino, the Navigation mode is back on “Ziel Kamera Modus” instead of “Objekt Modus”

Need help, please

Hi @martinsiegrist,

I think your issue stems from two separate problems in the 3DConnexion software:

  1. When you only change Navigation Mode settings the software does not save your changes. You can test this by making the change to Model View, closing the 3DConnexion app and then looking in the custom settings folder
    Appdata\Local\3DConnexion\3DxWare\Cfg\Ext\ for a file with a name ending in settings.xml. If that file does not contain a setting for ObjectMode (or does not exist) it hasn’t been saved. (n.b. this is a different location from that given in their administrator documentation, which cites the Roaming folder instead of the Local folder.)

  2. When you open the Advanced Settings panel, the software does not load your customised settings, loading the defaults instead.

So as a way to make this work, pending 3DConnexion fixing their software, the trick is to change the Navigation Mode, then change one of the button settings before closing the app. That should cause both changes to be saved (in separate .xml files) and you can check again for the settings file mentioned above.

If the custom mode has been saved, carry on using Rhino and do not reopen the 3DConnexion app as it may remove the custom setting!

If this workaround helps, perhaps you would be so kind as to share these notes with your contact at 3DConnexion.

HTH
Jeremy

p.s. A caveat: this worked with my version of the 3DConnexion software which is 10.6.3 - I haven’t yet tried it with the current version.

1 Like

I just tried this. The file starting with some numbers and the ending …settings.xml updates when I change settings for Rhino in the 3dconnexion app. But when I close Rhino, the folder ext is cleared.

Ok, so I it seems I can save the settings but when I open the app again, it jumps to default navigation mode which would be “Camera Target Mode”. I open the app and the settings in the app show “Camera Target Mode”, close the app but Rhino still navigates in “Object Mode” as defined via _SpaceMouse _Popup.

That means the app does not access the navigation mode settings correctly.

@Markus

I had the settings file open in an editor, so I didn’t notice the folder being cleared. And then when Rhino is restarted the folder is repopulated, but without the Navigation Mode setting in the file. I cannot see the information being written to any other files at around the same time as to the Ext folder.

It is confusing. Hopefully someone at 3dconnexion can fix the problem.

I found the XML file where the defaults are held and changed the default to Object Mode. Rebooted, opened Rhino, checked 3DConnexion settings: now defaulting to Object Mode. Yippee! Went to use Spacemouse and all movements are reversed. Closed Rhino, set default back to Target Camera. Rebooted, restarted Rhino, checked default back to Target Camera, Yes. Back to Spacemouse: movements still reversed. Change 3DConnexions app setting to Object Mode. Movement back to normal and continues running in Object Mode after Rhino restart, but settings back to showing Target Camera.

I think that’s the only sane conclusion: it is confusing.