Layout: X-Ray all wires in shaded display mode is disabled and yet wires are shown

Hi there,

I have to detail views on my layout plus I am using shaded mode. The object is drawn in 3D and I don’t intend to use Make2D for my layouts.
In top view the wires are not displayed, but in front view - although both details use the same settings. For further explanation I attached some shematic sketches. Which setting am I missing?

Thanks a lot!

have tried unchecking the ‘curves’ or ‘mesh wires’ options ?

Hey milezee! Thanks for your response. Unfortunately curves and meshes have nothing to do with the problem I have described, since the 3D objects are closed polysurfaces and closed extrusions.

ah I see, apologies, I misunderstood, is there a reason for not using Make2D ?

Yes there is a reason: The objects change all the time during the project - Make2D would take a lot of time.

Could you please post a 3dm file that shows what you are seeing? I have a hard time figuring out what this is about…

Hi wim!

thanks a lot for answering at all. Sure, here is my 3dm File:
180416_Rhino_Layouts_2.3dm (385.2 KB)

Could anyone please check my question out again!?
It is still not solved.
In case you need more information to understand my question I am happy to help.
Thanks again.


This is what it looks like for me in Rhino 6:

Is that correct or wrong? Are you using Rhino 5 or 6?


In my Rhino 5 it looks like this:


Hi David,
I am using Rhino 5. The Screenshot when you opened it in Rhino 6 is correct. Unfortunately mine doesn’t look like this.
I have not idea, why it looks all red in Rhino 5 for you.

It seems to have something to do with surface edges settings. When I disable it, there are no line. The thing is, that I need the outer lines to show, but not the subconstruction lines.

I think I finally got it :sunny:
Because that object is very far from the origin and has relatively thin walls, the edge curves from the inside surfaces are showing through the meshes of the outside surfaces.

Best thing is to move everything to the world origin. Alternatively, you could put a simplified model of that one object in place and hide the more complex version in the detail view.

1 Like

While this is what I get in Rhino 5:

Rhino 6 has double-precision meshes and a lot of improvements to the display and without moving the objects closer to the origin, this is what you would get in Rhino 6:

1 Like

I moved it into the origin. Unfortunately I get the same result. Hidden lines show.
What I don’t understand, that they dont’t show in top view. Although it is the same object. Is there any possibility to modify views?

In a test on your file here, that could mean that some other geometry is still far from the origin and not hidden (though not necessarily in view in the viewport). Try to hide all other geometry.

Also, you could try to use a smaller number in the TestZBiasFactor command. Here 0.25 seems to work.


Wim, thank you!!! It worked! You where right. There were objects in the drawing which where to far away from the object. I change that and moved them closer together and now I have my result.


Since I have files with lots of objects I need all the time and therefore can not hide them I looked for other solutions. @Wim: TestZBiasFactor really is the key.
Only that the command on its own didn’t work so well.
I am using this now: '_NoEcho _TestZBiasFactor _Less _Enter_NoEcho _TestZBiasFactor _Less _Enter.
For that I created an Alias under Options - New and added the upper command.
I know the programm warns that I should contact Rhino technical support if I need it to often, but for now it works for me.

That’s fine. If you needed to run this often in Rhino 6, that would be a different thing.

I’m not sure if you are saying that the only way to get this to work is by running the command 2 times. That is, doesn’t it work by specifying the amount in a single run of the command? Like so:

'_NoEcho _TestZBiasFactor 0.25 _Enter


'_NoEcho _TestZBiasFactor _Less _Less _Enter

sorry for the late response.
@wim: for very detailed drawings with this command: '_NoEcho _TestZBiasFactor 0.25 _Enter I need to run it 4 times for the result, with the other one as well. I tried different factors like 0.1 or 0.75 even 0.9. None had a better result. Somehow I don’t understand it why?