Layer Visibility

In V6, sometimes when I make a layer visible, that one layer becomes visible.

But other times, every layer because visible.

I presume there is some subtle user interface difference. If so, what determines which behavior occurs?

If you have a range of layers selected, then turning one On/Off effects them all.

That said, a range of selected layers is very visually obvious so not likely what you’re doing, but it’s the only thing I can think of.

The parent/child layer visibility is very buggy, and is now very frustrating

When I open my Rhino file this morning, my detail views are all messed up. The parent layers are still OFF in the layer panel but for some reason the child layers are all ON and visible in the detail view port.

This happens randomly, some days it’s fine, some days it’s not. Can this be looked at becasuse it’s very frustrating and TBH AutoCAD does a better job at this
image

This is what it should look like, I have printed a pdf with it previously (a few weeks ago)

But this morning, when i open the Rhino file, all children layers under a OFF parent layer is ON, and looks a mess :frowning:

If @John_Brock or someone can point me to the right person to look at this on going issue, that would be much appreciated!

Hello - are there linked blocks involved?

-Pascal

Hey Pascal, happens to both linked block & document layer

@pascal, I can actually replicate this using just the Rhino Template

After creating a layout and add a detail view in the newly created layout

  1. Activate the newly created detail view
  2. Nest “Layer 01” into “Default”, then turn off “Default”, then I can still turn on “Layer 01” (any all children layer of “Default”)

I think this is a bug, and has been for a while. I’m on R6
image

Hi -

I don’t have Rhino 4 installed but this behavior is at least present in Rhino 5.
This was earlier reported as RH-53775.
I am not sure if this is intended behavior but since it has been in Rhino for so long, I imagine that some users depend on this feature.

At any rate, that behavior doesn’t explain what is happening in the situation that you described further up in the thread. If you have set detail visibility states of layers one day and come back the next day to see that these are no longer the same, then something is very wrong. If you can find a way to reproduce that part, please let us know so that this can be fixed.
-wim

Hopefully not interrupting, but what I wrote about in the original post I never saw until V6. That is, when I click on a layer to make it, every layer becomes visible. I have not found any pattern this. I thought that this might be a feature and there was some special way of clicking to show all layers. I have not seen clicking hide all layers. It appear totally random for me.

Hi /

As far as I recall, I haven’t seen any other reports of that so far. Please keep an eye on this and see if there’s a pattern.
-wim

Thanks @wim, I will keep tracking this issues.

Otherwise, i will try code a tool in python that turns off children layers if the parent layer is off in an active detail view?

Hi @wim

The simplest solution appears to be making a copy of the problem detail view in question, this seems to update all layer visibility within the detail view (the original and the copied). I don’t know if this behavior is intentional or not though.

Hi David -

I’m not sure what you are saying here. It sounds like you can reproduce the issue of layer states changing all by themselves between sessions. Is that the case? If so, can you post a file and detailed steps to reproduce that?
-wim

Hi Wim

In the attached file, you will find a layout named “Page 1”, in it, you will see a detail view with layer visibility as per the first screen shot, where the parent layer “Shapes” is turned OFF, but the children layers are ON in the detail view and are visible in the detail view. Understand some might find this useful but for me, this is an error.

However, if you copy the detail view with command “Copy”, the layer visibility will reset for both the copy and the original detail view, as shown in the second screenshot

Layer_DetailLayerVisibility.3dm (75.2 KB)

Hello - I see that, thanks - toggling the Shapes layer on and back off again resets the visibility as expected.

RH-61508 Layer: detail visibilty incorrect

(btw, tested on Windows, here… same problem)

-Pascal