Show/Hide Layers in Details


In the past I was able to show a Layer in a Detail View even though the Layer itself was off in ‘model space’. I can’t seem to do that now.

Is there any way to revert back to the old behaviour?


(Brian Gillespie) #2

I second that. It is awful now, almost unusable.

There are at least two bugs on our bug tracker about this. Here’s one of them: (our bug tracker is not public yet, so you won’t be able to see it.

@dale, @stevebaer, this would be great to get in a V5 SR, or a very early V6 beta.

(Brian James) #3

This is working for me here with ‘ShowLayersInDetail’. Were you using the layer dialog visibility icons after a layout is created to do this? The bug report mentioned is specifically about the use of the icons for visibility control in details.


Hi Brian,

Yes I was using the lightbulb icons in the Layers dialog box. It’s good to know I can use the command line until the icons are fixed.



This behaviour seems to have been removed. It’s a real shame because being able to choose what layers to display and hide in a detail is essential when you have many layouts and want to display a number of options.
detail visibility is pretty much useless if it’s tied to the master visibility. Actually when you double tap a detail it should only display detail visibility, not detail and master. this just over-complicates things and doesn’t give any real advantage.


Just trying to revive this topic.

We need to be able to set Detail Layer visibility independently from the Master Layer visibility.
As it currently works in v6, if you want to see a layer on in a Detail, it has to be on in Model Space. This creates a lot of unnecessary complexity.

It used to work but now it’s gone. Any chance to revive it?


Hi Brian,

Just trying to revive this topic. ShowLayersInDetail, doesn’t seem to work in v6 nor v5 SR14.

It would be great to get the functionality back that was there before.

(Brian Gillespie) #8

Hi @Andrew - if this feature gets implemented, the soonest it will show up is Rhino 7. You can see the status of the issue in the YouTrack issue at the top of this thread.


Hmmm… the documentation “New in Rhino V6 for Windows” on the McNeel websites states that V6 will “Allow a layer to be off in Model Space and on or off in one or more Details”. Here’s a screen grab:Off%20in%20modelspace

@mary ?


Yep, I couldn’t get that one to work correctly here (maybe I don’t know how to use it), and I think the script should still be easier if you want to turn on/off a layer in all details…


I hope this to be true, this is one big issue when producing many layouts. Can not try because I’m on Mac but if anyone could confirm this new feature I would appreciate it. Thanks!

(Brian Gillespie) #15

Looks like that was a mistake - this feature was not implemented in Rhino 6. I’ve taken it off the web site.


Hi @brian, Will this be implemented in V6? This is a serious limitation when using Layout. Thanks.

(Brian Gillespie) #17

No, it won’t be in V6.


Sad news, thanks for confirming.


Hi Brian, Yep a bit disappointing, but I guess there must be a good reason to take if off the list…

(Brian Gillespie) #20

The reason we took it off the list is because it was added by mistake. We didn’t do all the work to fix this feature and then undo that work - the work was never done in the first place!


My experience was that it worked in many early versions of v5, but was changed as it was considered a bug!


Incredible but true!


Any chance we could get some behaviour that replicates the Show/Hide in Detail plus plugin? This plugin doesn’t work in (4.4 KB)

… even as a test command?

I have a file set up with 30+ Layout sheets most with multiple details.
I have just created a new layout that has an object in it, which only wants to display in one Detail on this Layout. It is a large object which will show up in all other Details.

To do this in v6 currently, I have to go through each Layout, Detail by Detail, and switch off that object’s Layer Detail visibility (or use HideInDetail)… Pretty tedious.

Previously this could be achieved by either:

  • having the Global layer off and only on in that one Detail
  • using Show/Hide in Detail Plus.