Layer color swatch issue

@stevebaer this should change IMO. It’s very confusing. Last time I got a file and searched, restarted Rhino, changed display settings etc. etc. only later to find out that it was the layer color set to transparent. If the color is (partly) transparent then this should also be visible in the layer color or object color patch preview.

@Gijs can you send a screenshot of the control that is not showing transparency properly?

I’ll check it out tomorrow

1 Like

@stevebaer

When a layer is set to transparent, it’s not visible:


until you either open the properties:


or open the color itself.:

The general way of showing transparency with blocky background works best I think, just like the color picker.

Furthermore, slightly related to this: I always use different color for backfaces (red) in shaded view. But this does not work very well with solid objects and transparency:

2 Likes

Yes, I discovered that today also - the backface color overwhelms the transparent object color.

1 Like

Yep, thanks, I see that - I guess it is related to this -
https://mcneel.myjetbrains.com/youtrack/issue/RH-61549
But I’ll make a new bug for this.
RH-63194 Display: backface color overrides layer transparency
-Pascal

Not just layer transparency, it also affects individual by-object applied transparency.

Thanks Gijs, this looks like a Mac specific bug.
image

I made a bug report for this at https://mcneel.myjetbrains.com/youtrack/issue/RH-63196

@steve, thanks. There is some inconsistency in this in Windows too: when I set a layer to transparent color, it looks good in the layer panel, but in properties, I don’t see the transparent icon of the layer.

But if I click the dropdown, I do see it:

When setting to custom layer color, I see the transparency:

Gijs -

On the list as RH-64436.
-wim