Latest version of GH and .NET framework

Hi there, I have to import a library into my C# but the operation fails, seemingly due to incompatibility of the .NET frameworks used in GH and the library (written in .NET 4.6) the does anyone know what is the version of the .NET framework compatible with the latest version of GH? Is the latest version of GH from 2014?

You can run the C# component in the attached file to get the .NET version currently running in your Rhino.

DotNetVersion.gh (3.3 KB)

1 Like

Hi David, thanks for your response, by running this file I realized you have released GH 0.9.0076 is quite old and the .NET framework is 4.0! Where can I find the new version you are using? is it part of the Rhino WIP?

Yes, every weekly Rhino WIP whips with a Grasshopper 1.0 version. This version has by now accumulated a lot of new features and bug fixes (though no single major thing apart from screen aware dpi scaling UI).

Hey, I don’t want to create another topic, because I have the same question, I tried the same component to check .NET version in Rhino 6, and it’s 4.0 for me, but I saw somewhere that if you want to develop plugin for Rhino 6, you can use 4.5 version safely. What is the latest version of .NET framework that I can use to develop plugins right now?

You can safely use .NET 4.5 with Rhino 6. We ensure that at least 4.5 is being used

1 Like

Dear @stevebaer
Setting up a new computer with visual studio etc… i came across the questions - which .NET Framework Version to use ??? (and to install) to develop Rhinocommon c# plug-ins.

-> does it make sense to start new projects with .NET 4.5 ?
to reach maximum number of clients / compatibility

or

-> does it make sense to use the latest .NET 4.8 ?
to have most functionality / most future oriented setting ?

to connect this topic:

WIP 7 seams to use .NET 4.8

Rhinocommon seams to be compiled against 4.5

Maybe an update of this article would be helpful ?
als far is i understand Visual Studio 2019 is now supported.

thanks for your info - best - Tom

That’s a call you’re going to have to make. Rhino 6 and 7 both use the most recent version of the .NET framework installed on a user’s computer. In the case of Rhino 6, we made sure that at least 4.5 was installed. In the case of Rhino 7, we bumped that up to 4.8

Maybe target 4.5 until you find something in .NET that you absolutely need access to. Just a suggestion.

1 Like