Latest Rhino 64-bit SR Update changed language settings from English to Czech. I am not able to go back to English


(Petr Benes) #1

Hi

I updated to Version 5 SR6 64-bit (5.6.31003.3365, 3. 10. 2013) running Windows 8 and my language setting was changed from English to Czech. Although i have set English in settings and after Rhino restart I still have Czech menu and commands. I want it back to English as i used it before. Is it some bug? I am not able to set it back to English.

Can you please help? Thanks

Petr


#2

Hi Brian
I have a same problem language italian- english . If i set English i get Italian.
Last SR6 64 bit
Ciao Vittorio


(Petr Benes) #3

I solved it by uninstalling the Czech Language Pack to have there only English. But this is not sophisticated solution.


#4

Yes, there have been several similar problems reported with multi-language and non-English installations. I don’t think they have got it fully worked out yet. The solution in my case was to uninstall Rhino and reinstall (either from the disc or from the latest SR5 download) including all languages desired, then update to the SR6 RC.

–Mitch


(Steve Baer) #5

@brian any ideas?


#6

I have the same problem over here. I installed both German, Spanish and English. I can change to Spanish, to German, but if I choose English, it will remain in the German language, that I am not good at. Not at all, actually. Please help.


(Brian Gillespie) #7

Thanks everybody for reporting this. I am currently working on reproducing this now. It looks like the central problem is that Rhino 5.6 isn’t selecting the language properly on non-English versions of Windows. I am building a Chinese Windows 7 x64 virtual machine now, and will be able to test this shortly.


#8

I have found an easy way to work with it now. In the folder C:\ProgramData\McNeel\Rhinoceros\5.0\Packages, you will find allt he files for all the languages you installed. You (temporarilly) move all the language packages you do not want to another directory and leave the en-us files there. start Rhino again, it will only use the English language package.


(Brian Gillespie) #9

Michiel, thanks for posting the work-around. In the next RC, this bug will be fixed.


(Brian Gillespie) #10

SR6 RC3 is now available, please test it and see if it fixes this problem for you.


#11

Bingo! RC3 seems to have fixed my workstation (without having to uninstall/reinstall). Everything in French now looks normal… except one minor item I noticed (not mission critical, but).

Under the French interface, when I pull down the language choices in Options>Appearance, the items are listed in English:

French, English

and not in French

Français (France), Anglais (Etats-Unis).

It’s admittedly a minor niggle, but you might check what’s going on there to avoid complaints from others. I checked my other installs of SR6 and they are the English as per the image below, when I checked my colleagues’ installs still on SR5, they are all in French.

Thanks,

–Mitch


#12

Note also that on one of my installs (laptop this time) the same three items I mentioned earlier on in Options - Licenses, Toolbars , Updates and Statistics are still in English (just the names in the tree…) as well as the tabs in the splash screen… On the others, they are in French as they should be (with Rhino in French). Curiouser and curiouser…
–Mitch


(Brian Gillespie) #13

This is strange. You should see the languages listed in the language that your OS is set to. This is how V4 and V5 have always worked - are you sure V4 shows the languages differently on the same computer?


(Brian Gillespie) #14

That’s even weirder. If you switch to another language and back to French, is it still this way? Are you using command line arguments to start Rhino in French, or do you switch from in the Options dialog?


#15

Ah, OS language… not Rhino language. OK, all my OS are in English, my colleagues in French, so that makes sense. I only have V4 on one machine, I’ll double check at home tonight.

Thx, --Mitch


(Brian Gillespie) #16

Yeah, that is the only place in Rhino where we use the OS language. If you are running English OS, then there is no need to check V4.


#17

That seems to have fixed itself… I have 3 different schemes (English - my workspace, English Default and French Default), so I usually open directly in the appropriate language languages with those.

Thx, --Mitch