Keyboard commands and shortcuts not responding


I’m hoping someone can help me with this, its getting very frustrating.
My keyboard commands and shortcuts aren’t working sometimes. I originally thought it was the keyboard, maybe it was the batteries being low or a faulty keyboard but i have changed the batteries and have the keyboard works fine with all other programs.
When i press esc it takes pressing it about 6 times before it works, if at all. When I’m typing a command in, some of the letters won’t show up and the shift key wont work sometimes.
And its not that i’m not hitting the keys hard enough. Its also a very recent thing. Its only been happening less than a week.

Any help would be very much appreciated.

Mac or Windows? Do you have anything else running in the background that might be disturbing the keyboard input? Non-standard plug-ins, attached devices etc.?


Hi Mitch

Its windows. i dont think i have anything else running. I know photoshop can be disruptive to autocad but i havent got anything else running. Its odd because its fine for maybe an hour and then it will stop responding again.

Dunno, maybe when this happens press ctrl+shift+esc to get into task manager and see what’s running in the background and if anything is hogging your resources like the processor… --Mitch

Hi Stephanie, are you running any plug-ins, like say Grasshopper, maybe?


Nope nothing else is running Pascal.

Hi Stephanie - just making sure we are on the same page - I mean plug-ins in Rhino, not a separate program running. I ask because I seem to remember that Grasshopper, in some cases, can mess with keyboard input. Are you running Windows on PC hardware or Bootcamped or? You might try refreshing the drivers for the keyboard as well, if you have not.


I’m having the same issue - deleted short cut i.e, ctrl-shift-1 is !_BooleanSplit

Worked for two years and suddenly doesn’t work. Also happened with MatchProperties ctrl-N

Why would this be happening? Maybe it is a rhino 7 issue

Hi Cole - are the shortcuts still showing as expected in Options > Keyboard page?

Can you please run the SystemInfo command in Rhino and copy/paste the results here?


Did some trouble shooting and realized there was another shortcut from a newly installed application that was interfering with Rhino because they were the same shortcut

So all is working and it is not Rhino’s fault!