Kangaroo tensile

Hello!
Im trying to make something like that -

but with one mesh but i must be doing something wrong since the mesh is not moving at all…
Here is my gh.
kangaroo help.gh (16.5 KB)

Any help will be very appreciated

Dear Eli,
Perhaps this helps?kangaroo help_V1.gh (15.7 KB)

2 Likes

Hey,
Thanks, but im trying to have the mesh divided into smaller modules, like in my img
Kangaroo%20help%20img%2001

but as one continuous mesh (i made each module as a separate mesh)

Here is where i got with your definition
i understand that something is wrong wikangaroo help_V1.gh (16.9 KB) th the anchors but i cant fix it

Any Ideas?

check this way:
kangaroo help.gh (27.2 KB)

1 Like

Great! thank you very much

Hello,
With a lot of good tips in the forum, i mange to do this:

but i still have 2 issues:

  1. i want the tensile shape without the openings, how do i do it?
  2. i dont understand why when im moving the Anchor points manually it doesnt change anything in the form.

thanks

kangaroo help E03.gh (10.7 KB)

is it even possible with kangaroo?

@EliabuRada a sketch of the final form would help us understand requirements lot better.

by setting all the points along the edges as anchor points.

Notice that in what you intended originally those ‘openings’ were always part of the result…

I haven’t opened your attachment but if you intend to manually drag anchors then you might need to use the grab component from kangaroo, set it to true and connect it to the engine along with the other goals


something like that

1 Like

Yes,
the problem is that i want to maintain my subdivisions in this case the naked edges will give me both the contour points and the internal in one list

So i manage to make this:

but i still not able of manipulating the shape by moving manually the points - when i move one of them the shape is acting as if i moved all of them .kangaroo help e04.gh (15.4 KB)

I opened this (your latest) file - for whichever reason you’ve chosen to go back to using kangaroo 1 - the example provided earlier was using kangaroo 2:

Perhaps what isn’t clear at this point is whether or not you’re familiar with the plug-in version(s) and/or the grasshopper functionality for internalized geometry, like your points, which, if you intend to drag manually ,then they must be selected (clicked on) in grasshopper first for the manipulators to appear:
image

Hey im using them both, 1 and 2 when i see that with 2 i cant get to what i want im trying with 1.
I am familiar with how to move gh points.
but yet when im moving them nothing happen to the shape.

got you

I opened your file

hit the reset button

selected the point(s)

dragged a couple in rhino

geometry moved up:

true, but what i mean is that when i move 1 point the all geometry moves and no only the mesh at this point

Hello, me again,
Still struggling,
So i took this :


and tried to work on it to make something like this:

here is how i tried, but its not working - i am guessing its something with the anchor points that i moved up, but im really lost here…
kangaroo liap.gh (31.9 KB)

You need to start with the right topology, so if you want 5 faces, you can start from a box, remove one side, then set different tensions for the edges:

boxtensile.gh (12.3 KB)

2 Likes