Kangaroo membrane simulation flies away

Hey,

I have been trying to create a membrane simulation in Kangaroo which worked first few times I ran the simulation but then suddenly started to fly away and I can’t find the issue what has changed or why it does so…

Has anyone got some tips? I attached the image of the definition.

I will really appreciate some help, thanks :slight_smile:

Have you tried starting the sim with the load force vector at 0 and then slowly raising it?

hey, thanks for your answer!

no, I haven’t tried it but will give it a try as well!

in the forum here

i was suggested to extract the anchor points from the last geometry that I am going to plug in the simulation. It seems to work now well, but I will check out also your suggestion :slight_smile: it’s always good to have a couple of options to work with

Hi Marija,
There are examples of how to do tensile structures like this in Kangaroo2 here:


Probably the one ‘SimpleTensile.gh’ is most useful.
I’d really recommend trying the new Kangaroo - it solves a lot of problems from Kangaroo1 with stability and the timer, and it makes it easier to do things like this where you change the position of the anchors.