Kangaroo Grab Tool glitch on latest RH7 SR for Mac

Hi guys, after upgrading to the latest RH7 service release on Mac, I noticed this glitch with the Grab tool.

I’m running Rhino 7 v7.9.21222.15002, 2021-08-10 - GH 1.0.0007 - Kangaroo 2.42.

It seems due to some conflict with other mouse commands in Rhino (but I haven’t found ways to deactivate the selection tool). This tool was working perfectly with the previous RH7 service release, as well as on the RH7 Windows counterpart.
Any hint?
Cheers, Andrea

1 Like

Hi @ndrRH

You mention Kangaroo 2.42 - do you mean you installed a version downloaded from Food4Rhino?
Kangaroo comes as part of Rhino 7, and the version included there is the most current one.
Installing older versions is likely to cause conflicts, and if the older version is loaded then some bug fixes will be missing.

Sorry Daniel, please ignore the comment on 2.42 - I confused it with another installation.

I confirm that the problem happens with the default Kangaroo, the one coming with Rhino 7.
We experience this issue over different machines such as different generation Intel MacBook Pro’s as well as MacMini M1.

Are you aware of any possible change on mouse functions between the last two Rhino service release updates?
Thank you

I’ve noticed this too recently. I simply don’t use the Grab component that often.

Hi @DanielPiker

As we are stuck with this on a couple of jobs, I wonder if there is a combo key or any way to force the Grab component to overcome this issue.


Hi @ndrRH

Sorry about this. I’m not sure exactly what happened here, but I suspect it might be related to some changes I made in relation to this thread.

I’d be interested to hear if the alternative grab I posted there works for you or not.

Thanks Daniel,
I tried your alternative grab component and it seems to not work here.

Thanks for testing. It looks like the change I made that fixed their issue on Windows somehow broke it on Mac. I’ll try and make a similar standalone gha fix for you to go back to the old grab until I can find a way that works on both.

1 Like

Hi Daniel,
I’m experiencing the same issue --thank you for looking into this.
Are there any updates?

Hi @user692

Sorry for the delay with this. For now here’s a temporary Grab component replacement that works on mac
GrabFix.gha (9.5 KB)
Install it the usual way, then in Grasshopper under the Kangaroo>Main tab, you should see a component without an icon (so just a grey/white checker pattern), called GrabFix. Use this instead of the normal Grab component.


Thanks so much!
I will install and try today.



Worked great on my Mac.
Although, some of my students with Macs were able to use the original grab and it worked fine. I know this could be the opposite of helpful as I’m providing extremely little detail, but I thought you might like to know.