Issue trimming curves since Rhino 6. Settings or perhaps bug?

Hello all,

I have had an issue trying to trim curves that has been coming up in my workflow a couple of times since updating to Rhino 6. When I trim curves I have been left with a sliver that doesn’t allow the curves to close. I don’t know if its a certain technique I’m using that encourages this issue or if there is a tolerance setting that could change things.

This shape was made from 4 circles. All circles were highlighted and then ctrl T. Clicked off the excess and I’m left with the little slivers shown in the pic on the right hand side.

This doesn’t always happen. In the attached rhino file I copy pasted the problem shape from a more complicated file I’ve been working on. I only noticed the issue long after I drew it while trying to extrude it.
In the attached file I drew another version of this shape and it worked as expected creating a closed shape at the end.

I have had this issue several times now ignoring it until now. Seems like it keeps showing up so I’m now piping up about it. Thanks for any help or guidance!


trim issue.3dm (44.1 KB)

Hi Chris - I just tried this in your file - made new tangent circles between the arcs - and trimmed it all - it looks clean here, so I am clearly doing it wrong - can you post a file that shows the problem but Undo the trim before sending?


Thank you for the fast response!

I wish I had that available. The curves with the issue where made long before I found the problem so I cannot undo the trim. The file does however show the result of a trim, I can vouch for that.

I can keep a close eye on my workflow and try to catch this sooner as I have come across it before. However, its not every day in frequency. When I see it again I will post up a file.

Full disclosure, I was able to simply zoom in on the problem curves and trim them again to get my final closed shape so I’m not hitting any walls.

Hi Pascal,

I tried messing around in my project to get this to repeat itself and I think I’ve done it. If I trim the curves in this file to come up with a semicircle slot like the attached pic above I get the slivers I’ve been talking about. See if that happens on your end.

trim issue.3dm (912.3 KB)

Hi Chris - to clean up, if you run into this again, a couple of commands that could be useful:

ShowEnds (for the joined curve that may or may not be properly closed)

I see your file, I’ll take a look- thanks.
Yep, I see that. Hmm - it’s interesting that if you Intersect the curves first and use the resulting points to trim, it all works cleanly, so finding the int is not the problem, which is what I was looking for.


Your model is very small for its tolerance. Setting the absolute tolerance to 0.0001 instead of 0.001 solved quite some issues here.

The two points are 0.0155676 units away here, which is a bit more than the absolute tolerance you set, but not a lot.

Yep, but on the other hand Intersect finds the correct points, or correct enough to trim cleanly with, so it seems (to me) Trim ought to work as well. At any rate, I put on the pile for the developer - I’m sure he’ll set me straight.


Hey guys,

I’m having more trim issues that I thought I would show here. They are intermittent. Sometimes the trim works cleanly and sometimes there are left over parts. In fact I had to record the screen a couple of times to get the issue to show up like it did.

Hi Chris - I guess that reveals the seam points in the input curves. I don’t know how easy it will be to tune that up - I’ll test a bit here. But, fyi, CurveBoolean may be a help for this type of operation.


Thanks very much for the help so far. Lots of commands I am ignorant to.

Also, I don’t think this was ever an issue with rhino 5, which I must have trimmed a million lines in.

I saw this behavior when trimming from the perspective view, in the planar views works fine but as @Pascal says, the curveBoolean works better in most cases.
I guessit can be something related to the “apparent intersection” option because disabling it, works fine in the perspective view.