Odd trim behaviour

Once in a while, i come across an issue when trimming curves with lines.

I have two circles, which i’m bridging with tangential lines connected at the quadrant points. I want to trim the inner circle pieces and join the remaining semicircles to the lines to create an oval.

I select the two lines, use the Trim command, then click on the inner parts of the circles, which produces the following result:

For some reason, the curves are not getting trimmed at the intersection points (the quadrants of the circle). Clicking on the remaining pieces produces the following result:

Very odd indeed. So i hit Undo and instead, selected the circles, then used the Split command, selecting the two lines as the objects to split with. And that works as expected:

Has anybody else experienced this? I’ve attached my file for you to try.

dwTrimIssue.3dm (799.1 KB)

I’ll take a look, thanks- CurveBoolean might be good way to do this, as an aside.

OK – the file tolerance is .01, the radius of the circles, .03, way too close. I’d model this at .001 maximum if you have features this small in the model.

http://wiki.mcneel.com/rhino/faqtolerances

-Pascal

Ah, okay. I often forget to change my tolerances from the default setting.

Is it strange that Split works, but Trim doesn’t?

Template files are meant to get around this - when you start a new model, choose a template file (New from template)

-Pascal

Yeah, i made a default template for myself ages ago, but i think it may be time to go back and edit it. :wink:

Thanks for your help, Pascal!

One other thought I had in reading this, besides tolerances which Pascal already helped with, is the command ArcBlend which you might find useful in cases like this. You can drag the preview for varying the arcs used.

Since we’re piling on, here’s an excellent FAQ about tolerances in Rhino:
http://wiki.mcneel.com/rhino/faqtolerances