Isometry in Cycles (Cyclometry?)

Ah, bummer, I thought the thicker “silhouette” edges were something that the display mode figured out… --Mitch

2 Likes

The display mode is called Raytraced.

Nope… good ol’ fashioned human labour.

Incidentally here’s a screen-cap of the viewport:

What kind of rendering device do you use?

CPU, I get corrupted display (and sometimes crashes) when I try my AMD.

Device 0: CPU > Intel Core i7-6700K CPU @ 4.00GHz > 0 | False | True | False | CPU
Device 1: OPENCL_AMD Accelerated Parallel Processing_Tonga_01:00.0 > Tonga > 0 | True | True | True | OpenCL

You could try setting environment variable, see

for info.

@DavidRutten
your rendered view looks nice - would you share the setting? maybe even add this as another option to rhino wip?

That seems to work, adding the environment variable adds a third ‘device’ to my list, which if I select it is a one-way ticket to hard-crash central, but selecting the ‘old’ AMD device now works. It’s a little bit faster than CPU, not hugely. Is that expected?

I have to say it’s rather nice not having the ventilator kick in right away while using the card.

It’s standard settings, using one of the standard HDR environment maps.

@DavidRutten
ok, sorry, don’t get it. do i have to add the HDR somewhere in settings -> view -> display modes -> rendered? or somewhere else?

That’s a labour of love. Looks amazing… I’d have that as a poster or a screen saver, but then I’m old(er) and it brings back memories :smiley:

Render settings panel (the tabs where one can have layer manager, material manager etc), enable Skylighting and either set a custom environment, or let it use the same environment as the background.

got it, thanks. but there seems to be more going on, i mean the thick edges. is it made via a custom material?

The thick edges are done with pipe and a solid black material…

When does the crash happen?

got a similar look now. the gird is a small and simple texture as color on a custom material which i used as ground plane. but it’s also not displayed infinite, also AMD card :unamused:

@2DCube
thanks for the quote - should have read more carefully before posting, sorry.
can also be done in the display settings. Surface Edge Settings -> Edge thicknes (pixels)

Thanks David for the explanation. I wanted to know if that silhouette effect was automatically created by the renderer, but seems like It is not.

A few seconds after I switch to Raytraced using the new device.

Command: RhinoCycles_SelectDevice
Select device to render on (-1 for default, 0-2) <1>: 2
User selected device 2: ccl.Device: Intel Core i7-6700K CPU @ 4.00GHz (OpenCL), Id 2 Num 1 Name OPENCL_AMD Accelerated Parallel Processing_Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz_ID_1 DisplayDevice True AdvancedShading True PackImages True

Ah, the Intel OpenCL stuff seems to be quite buggy. I thought you were using your AMD device instead. OpenCL on CPU is probably not noteworthy faster than vanilla CPU.

edit: I probably should filter intel OpenCL devices out of the list until those become stable.

1 Like

If you mean that you see the groundplane edges when you zoom out a lot - yes, that is because Cycles has only float precision. On larger coordinates you’ll see render errors. That is why (at least for now) the groundplane has a finite size.

edit: nvm, I just see the problem you actually meant. Could you post the 3dm for me so I can have a look? Also info on your GPU could be useful (output of RhinoCycles_ListDevices and what you selected from that list)