Isolate Rhino Settings problem

Hello all, after unchecking the Isolate Rhino Parameter (Because I needed consistency between my two platforms, Rhino 7 and Rhino Inside Revit)
My Grasshopper Revit Library has disappeared and an uninstall, reinstall, hasn’t corrected the problem.
Here’s what I get when I try to open one of my script that worked fine before unchecking that parameter.

That’s odd. I tested in various scenarios and not able to replicate.

After restart things are back

But as soon as I uncheck that parameter, the Revit components disapear again

Thanks for the screenshots. It does appear that Rhino is opening in Revit without knowing it’s in Revit. I’ll dig into to this and see if anything has changed recently or what could possibly cause this.

Hi @thomas.lagarde,

Isolate settings helps to some users have a different set of plugins blocked in Rhino standalone than in Revit.

When you block a plugin it’s only blocked in Revit while still works in Rhino.

Maybe you have a conflicting plugin blocked on the Revit configuration that is not on the default one?

That was my assumption too, I will get you all the info needed regarding my config but I don’t have anything out of the ordinary.
Windows 10 Pro 64 Bits
Version 7 SR27
(7.27.23032.13001, 2023-02-01)
My grasshopper plugins


This would be a Revit plugin conflict

That seems to be a very isolated use case for such a parameter, how many people would actually want to block certain plugins in Revit ?
It could be a a possibility that one of the plugins is indeed conflicting Rhino from realizing it’s in Revit. I don’t really want to disable everything just for a supposition. I’ll wait a bit for @Japhy

How do you know ? Which plugin ?

Old Enscapes have had issues, locate the add-in folder, move the add-ins to a temp folder and start Revit.

Most of the time, the files you’re looking for are located in C:\ProgramData\Autodesk\Revit\Addins, but it’s not a guaranteed path. Some variations of this path could be C:%USERNAME%\AppData\Roaming\Autodesk\Revit\Addins\ or C:%USERNAME%\AppData\Roaming\Autodesk\ApplicationPlugins

It’s not the plugins, I removed everything there was and Grasshopper still can’t figure it’s in Revit. Everything started with unchecking the parameter and everything came back when I checked it.

To be honest, I wouldn’t care if my toolbar layout was consistent, there is only one default rui file but for some reason, Rhino Inside Revit doesn’t get it.

Same problem (Toolbar layout discrepancy between both versions) but different output.
If Rhino inside Revit is using different settings, where are they stored ?

Hi Thomas, I’ve been trying to replicate this, still with no success, we are working through a similar but different issue that could be related (possible a plugin conflict)

The Rhino settings aren’t in separate files. The file governing this is Default.rui

So I thought, that’s why I was curious about this difference.

Hello all, I tried to come back to this weird “Isolate” or not Rhino to troubleshoot something (it didn’t work)
Am I really the only one who gets that bug

Grasshopper doesn’t understand after unchecking that parameter that it is in Revit, therefore that setting cannot be used at the moment.

Can you try your 2023 with no plugins loaded? (per your ladybug thread)

I just tested again on 2022.1 with no issues.