Is there a setting to always render the last viewport rendered?

I almost always render the perspective viewport. After rendering in draft mode, I typically edit the model, often in another viewport, top, front etc, so it becomes active. After the edit is done, I hit render again, and 2 out of three times I forget to click on the perspective viewport to make it active again, and the wrong viewport starts rendering. There’s no way I can train myself to remember to click back on the correct viewport, 50% is best I can hope for. I vaguely remember having seen a setting that defaults to the last rendered viewport, but I can’t find it anywhere. Any help on this?

To make things worse, V-Ray always crashes when switching rendering viewports. It freezes, I stop the rendering, and at that instant the memory usage spikes from about 1MB to 20MB or more in 5 seconds, taking over all my RAM (16GB) and my hard disk (500GB SSD). Repeating this process several times a day is brain damage. It’s harder to find a solution for the V-Ray crashing problem (please advise if you have one, and I’ll contact Chaos too), so I’m hoping I can prevent it by not accidentally switching viewports.

Hello- in the Rendering panel you can set the view to be rendered - the default is the active viewport. I do not know how this interacts with VRay though.


Hi @pascal, I run in the same workflow issue from time to time and your solutions sounds great. I tried it and if I choose “specific viewport” or “named viewport” than the UI jumps a little bit. Should be there an input field where the user can choose the specific or named viewport from a list? The UI looks so empty there and I don’t know how to define the view.

Hi MIcha - Hum… when ‘specific viewport’ is set, there should be another dropdown below it -

look in the Rendering panel - is that any better than your DocumentProperties page?


I found the reason for the missing option. If an other render engine than Rhino render was selected before than the option isn’t shown. If I select “Rhino render”, close and reopen the option, than I get it. So, it looks like a small UI bug during switching the renderer. Maybe it could be fixed.

Thank you for taking time,

Hi Micha - yep, I see that, thanks.


Thanks for the help, it works. I knew I had seen a setting in the past, but it went away with V-Ray. Now I have to deal with the V-Ray rendering memory spikes, I think it’s a V-Ray issue, doesn’t happen with the native renderer.

@connie Best you ask at the chaosgroup forum and don’t forget to write, which version of Vray and Rhino you are using. :wink:

(Quick raw idea - did you enabled displacement?)