iRhino3D Update

iRhino3D version 8.7.24088 (20.0.0) is released via TestFlight

This is a big update. Please help me find and fix the bugs before releasing it on the AppStore.

What’s new?

  • User Interface
    The UI has undergone a complete rewrite as we switched the underlying UI framework. The experience should still feel familiar. I tried to make better use of space and declutter the viewport.

    Main navigation has moved to the side panel (on iPad) and bottom panel (on iPhone)

    Activate context menu help on UI elements with a long-press:

  • Markups
    Markups now use native Rhino geometry in the 3dm file. That means they’ll be there if you share the file with someone else or open it in Rhino desktop. (Don’t forget to save the file after adding a markup)

    You can see existing markups by tapping “View All”

  • Commands
    The Command line has a new look. Pin your favorite commands for quick access.

  • Scan a Room
    Multiple partial scans can be joined together.

  • Better Pencil Support
    Using an Apple Pencil you can model without losing the ability to change with the view with your fingers.


Nice! Thank you!


Looks great!


Looks good. The only thing I’m struggling with is the language. My iPad language was set to Switzerland and the app used German language.

With German language, the ‘Importieren’ button text is too wide and displayed on two lines.

I changed to language in my iPad to English so for me this is solved :slight_smile: I cannot work with German commands :slight_smile:


I don’t see another way to get around this problem. I think the best solution is to change the text size in your iPad/iPhone settings

1 Like

This is really good news! I wonder what the ‘alignment’ process is though… And not to mention the ‘trimming’ process that should be before the alignment process…

Then later we’ll need to go over the ‘decimation’ process. :coffee: :blush:

Thanks for the update! Im finding a weird behavior by the command menu that pops up when typing a command in the command line. It oscillates and I cannot actually pick a command.

Video is included. I am using ipad pro with apple magic keyboard and separate bluetooth mouse.

I’d like to request again the option to keep the command line persistent, so that I can start a command by just typing, instead of lookjng for a button every time I want to do a new command.

That’s weird. But not unexpected since I didn’t design this for physical keyboard input.
I added your comment to the wishlist item for keyboard input:

Can you share what keyboard model you’re using so I get the same setup from Apple Store? I can’t reproduce this by using my MacBook’s keyboard.

All of that is handled by Apple’s RoomPlan API, it’s pretty seamless.
I have to mention that at the moment the separate scans need to be done in one session for this to work.

1 Like

Thanks, this is the Apple iPad Magic Keyboard for the Ipad Pro 12.9-inch (3rd, 4th, 5th, and 6th generation). MJQK3LL/A

For good measure, I am using the Ipad Pro 6th Generation, MP643LL/A

The mouse is the Logitech Pebble i345.

1 Like

Hi @mkarimi

These are great improvements! I like the way you have organized everything on such little space. The graphical appearance and UX is superb.

I could just find a minor flaw on a small display (iPhone 14) in landscape mode, there is no way to close the main navigation. The dialog goes fullscreen and the bar on top disappears. You’ll have to rotate the phone to portrait to get out of the main navigation.

Next I need something with a LiDAR sensor :wink:

Thanks and keep up the good work,

1 Like

Good catch, I can fix this in the next release. Logged here;

This is now fixed in 8.7.24094 via Testflight


Hi @Brian_Chan, this is fixed in 8.7.24098 (11.1.1) when using an external keyboard.

I also tried to make it easier to use the commandline, it’s not exactly sticky as you requested yet but you can activate the commandline by pressing ⌘ + P

1 Like

Thanks for the fix, I can actually use the command line! I will play around with it.

To clarify my request for “sticky” commandline, I meant more that I like how in the desktop version, starting to type on the keyboard will make the commandline appear and receive the command , and then the commandline can disappear once the command is executed. I don’t know if “sticky” is the exact description for this behavior. What I like about this is that it has the fastest workflow, as I don’t need to perform steps (besides typing the command) to start a command.

Could I recommend a different request? Since I am using a mouse, I was wondering if there could be the option to make it that left click and drag is for moving objects, while right click is for navigating the view (usually orbit)? This would also be aimed at improving the efficiency, since so much of Rhino is about moving control points around.

In testing this version I find that the Object snaps have a bunch of on/off toggles in a line but I can’t see which ones I am turning on and off. Running “ShowOsnap” crashes the App.

Thanks for all your help. Despite my notes, I’m very happy about all the updates you have been adding.

that’s what I understood as well.

First we need to get drag working, then it should be easy to customize mouse interaction

You can see the state of OSnaps in the commandline, is that what you’re looking for?

Logged here: