Intersect Hang Bug

I’ve seen some reports here of intersect and intersect two sets causing Rhino to hang. My copy has developed what seems to be a more severe version of this problem. Running either command on even simple geometry (intersect a plane with a box) causes Rhino to hang forever, reliably. I’m running the most current Rhino 7 (7.12.21313.6341, 2021-11-09) on a windows 10 PC. This started out of nowhere yesterday after I never had a problem with it in the past. I also tried running Rhino 8 WIP just now and found the same thing happens.

The best workaround I’ve found is running the command through Grasshopper, which produces results fine. This is pretty annoying though, intersect is a useful command.

Any thoughts about how I could get it running again would be appreciated. I’d be happy to provide any diagnostic information that would be useful.


Run Rhino command SystemInfo and post the results here.

Do you have V-Ray? Is so try disabling it and see if that solves the problem. Similar problems with Contour were reported today and V-Ray appears to be the cause of those problems.

Yes, disabling VRay fixed it, thank you so much for the help!

Here is the output from systeminfo, with VRay still enabled.

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Commercial, build 2021-11-09
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 8-20-2021 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA RTX A2000 Laptop GPU (NVidia) Memory: 4GB, Driver date: 7-7-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.35
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-7-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Dan -

Someone might already have done so, but you might want to report this issue to Chaos Group so that this can be looked into.

Good thinking, I just made a post on their forum. Thank you!

1 Like

I’m having the same issue, and as you mentioned latest vray is causing the problem.

Rhino: 7.12.21313.6341, 2021-11-09
Vray: 5.20.02 (02 1206442) Nov 18 2021

Seems pretty consistent. Fortunately it’s easy to downgrade to a previous v-ray version. The person on the Chaos Group forum said the next most recent version works ok.