Intersect Command within a block creates invisible surfaces or linework; how to show intersections in Blocks?

unhandled

(Djhg) #1
  1. Create objects which overlap

  2. Make them a block.

  3. Open block edit and run intersect command.

  4. Close block

Surfaces in block instances no longer display in shaded mode.
Nothing except intersection linework displays in Technical, Artistic, and Pen view modes.

Is there a way to create line drawings showing both silhouettes and intersections without exploding all Blocks?
Neither checking Intersections nor Make2D command (nor Intersect, as above) will do this on my projects.


(Wim Dekeyser) #2

This is not happening in a test here so this is either file- or system-specific.
Please post your file and the outcome of the Rhino SystemInfo command.


(Djhg) #3

IntersectionDisplayExploration.3dm (561.5 KB)

Thanks Wim, The two instances of the block in the center have had intersect run on them. no surfaces display on them my system. The two instances of a similar block on the right had intersect run on them before they were made into a block and display correctly.

(I have a current project I’ve spent the last few weeks on; with a great many blocks, so this is a problem getting them to the documentation stage without intersections displaying unless I explode them all. Also because these blocks contain only polysurfaces they only display as hidden lines in tech, art, and pen view - the known bug, as I understand. So it’s becoming a problematic situation to determine how to create accurate documentation layouts.)

It’s Rhino 5, so I don’t have access to the “systeminfo” command. (Maybe Rhino 6 will correct this issue. I am still exploring the demo and don’t know if I can install the update in demo mode.)

Specificaitons:
Rhino 5 SR14 64 Bit (5.14.522.8390.2017-05-22)
i7-7700HQ @ 2.8 GHz
16GB Ram
Nvidia GeFroce GTX 1050i


(Djhg) #4

I believe this question may still remain.

I’m not clear on how to display intersections within a hidden-lines-removed line drawing view mode.

As the Tech and Artistic and Pen modes don’t display block linework properly, my hope with shaded view has been to somehow use the surfaces to simply occlude hidden lines but otherwise be imperceptible.


(Wim Dekeyser) #5

I’ve tested that file here in RH5 and what I see here is that the curves don’t show up in a shaded display mode but they do in the rendered display mode.

Rendered mode on top and shaded below:

In a custom shaded display mode, they do show up. I suppose you could try playing with the settings but not sure if that is giving you the HLR style that you want…


(Djhg) #6

Thanks Wim: I am not duplicating your success.

Can you tell me what settings you changed in your custom view mode to succeed in displaying surfaces (it’s not a problem with curves disappearing, but surfaces disappearing.)


(Djhg) #7

But maybe this doesn’t matter, because you seem unsure how to accomplish HLR with intersections displayed, which is my goal. Can you help me with a direct route to that? It seems basic, and an important feature of non-blocked object display in one of the three line modes (Technical, Artistic, or Pen.)

Is it simply not possible with objects in blocks? This is a very important question for the usability of the documentation tools in Rhino.


(Wim Dekeyser) #8

I never, ever use blocks. Way too many issues with them since the very beginning. Life’s too short…
Maybe a block-person has some tips? Anyone?


(Djhg) #9

Hmm. Thanks Wim.

With blocks seeming essential for efficient professional modelling, and display of volume intersections in line drawings essential for professional presentation, I can only assume that layout isn’t quite ready for prime time. I understand that at least one block-related bug (block objects containing only polysurfaces displaying improperly in line-only view modes) isn’t fixed in rhino 6 so I am not sure if further exploration is warranted at this point. It would be great if a McNeel person could help here.


(Djhg) #10

Attached is what happens when I attempt to display Silhouettes, Intersections, with hidden lines removed from Blocks in a current project. Nothing has worked so far, including exploding the blocks. I welcome any advice.

Specificaitons:
Rhino 5 SR14 64 Bit (5.14.522.8390.2017-05-22)
i7-7700HQ @ 2.8 GHz
16GB Ram
Nvidia GeFroce GTX 1050i

1-DisplayAsBlocks.pdf (2.6 MB)
2-AfterIntersectInABlock.pdf (2.4 MB)
3-AfterBlockExploded.pdf (2.6 MB)
4-PerspectiveOfObject.pdf (1.0 MB)


(Djhg) #11

Update: It seems that the anomalies on pages 2 and 3 - though always present when the detail view is created and the block is edited - correct themselves after a project has been saved, closed, and opened. It may require s save small to accomplish this. I hope that correction is permanent. If anyone has any idea what’s happening, please let me know.


(Pascal Golay) #12

Hello - have you tried this in V6 by any chance? I’ll test this on both myself but I’m curious to know if V6 behaves any differently with your card. Also, can you post a screen shot of

Options > View > OpenGL page?

Also, @djhg - you mention shaded mode and the several ‘technical’ based ones- are you saying that in the basic default ‘Shaded’ mode the surfaces do not show in the modified block or are you setting the technical modes to use shading?
Can you test, if you have not, with whatever modes look wrong reset to default?

thanks,

-Pascal


(Djhg) #14

In V6, the problems are just as unworkable. While the clipping plane display is a little more stable (though not completely consistent), intersections which display on one Block in V5 will not on V6, regardless of settings in the Display Tab. if I go into “Edit Technical Settings” and check (or uncheck) “show intersections,” the intersections will appear, but disappear again when the Options window is closed. Something’s not working properly.

There is a new problem today also. There’s a transparent object in this project which I have set to display in Render view mode in all views. Sometimes it does, sometimes it doesn’t; in both V5 and V6. Resetting the object display settings and view modes.

In these cases, closing and opening the project does not resolve the issue as in some of the previous issues.

My computer and video card was purchased in November to comform to the specifications on the Rhino website.
Please advise.


(Pascal Golay) #15

Hi David - thanks for testing - for now, please go to the NVidia website and get the latest driver for your card and let’s take it from there.

-Pascal


(Djhg) #16

Okay, thanks Pascal. That website actually recommends that I use the driver from the computer manufacturer (dated last year), but I will install their current one and let you know what happens.
D


(Djhg) #17

Unfortunately the issues are still there with the current Nvidia driver.


(Djhg) #18

I was hoping to work around all this with Make2D, but I can’t get it to create intersections - or it does I can’t get them to display. Please let me know if there’s a solution to this.


(Djhg) #19

(For what it’s worth, the intersections are still present in all three blocks because they display when each object is selected. One of them just won’t display.) I could proceed to create intersections on top of the previous intersections in the one misbehaving object and see if that corrects things , but my instinct is against duplicating elements over top of one another, which seems often to create new CAD issues.


(Djhg) #20

PS I deleted the post with the screenshot - but can provide you with the information if you need it.


(Djhg) #21

The text from that post was:

Thanks Pascal.
Screenshot attached as requested.
I’ll try V6 tomorrow I guess. I’m using the V5 demo at the moment.
I think that saving/closing/opening is resolving most of the issues (though the situation is a bit cumbersome and isn’t inspiring the greatest of confidence…) but getting clipping planes to display in any view mode is still completely hit and miss, and that doesn’t seem to be going away.
regards
David