Intermittent raytraced issues

I’m guessing that this happens < 1 in 10 times I render, maybe 1 in 20.

Anyway, I used _viewcapturetofile to save a raytraced image and saw artifacts in the final image.

I haven’t been doing as much rendering as I used to but I recall seeing, and ignoring, these artifacts some months ago. I can fix them by switching back to ghosted or shaded and then going back into raytraced.

I see white, over-saturated looking, “circles” or rounded ended lines.

Look at the picture with yellow highlights around the areas. I will include an undedited picture so you can see them once you know what to look for.

I forgot to mention that once I fix the problem by switching view modes: it stays fixed. (I think)

I haven’t seen anything like that.

If you can reproduce with just the glass dome part could you please share just that part exported in a 3dm file?

Is there a file size limit? I even removed the big exr file that lights the model and I still couldn’t upload it.

You can use our uploader at to share the file with me. I’ll be notified when the upload has completed.

I thought I saw a simpler way to show the problem so I made a very much reduced model (a single surface). I did this because I saw an extra light patch on the saucer and tried to reproduce it with the outer surface of the saucer.

Although the light patch is odd, it doesn’t go away when I switch view mode back to ghosted from raytraced then back to raytraced (the view mode changes usually fix the problems I see).


The shadow line across the saucer was very odd and was fixed by toggling view modes.


The white blob is odd, I’m not sure what it is and it changes or goes away as I move around the model but maybe it’s just a reflection of the sun.

But the shadow issue is fixed by view mode toggling so could be related to the other issue that I reported above. It might be something that only happens the first time you do a raytraced view after app start.

I will use your upload link to upload the simpler file.

To be clear: I saw this in the viewport when in ratyraced mode. I didn’t need to do a _viewcapturetofile or a render to see it.

Could the problem be due to the fix to Sun lighting between Rhino 6 and Rhino 7.

In Rhino 6, even with a very smooth surface, the shadow from the sun was jagged (as if there was no shading interpolated across a poly). This gave a rectangular stepped effect.

This problem was fixed in R7.

Or it’s just a one-time init problem.

Or something else. :slight_smile:

This white highlight looks like the reflection of a light. The sun if you have it, or some other light in case you have those.

Not sure what the wobbly shadow line is about. Looks like it is following the curvature of the surface - maybe a reflection line.

I’m using the Rhino Sun feature to add, well, sunlight to the scene.

But the exr is a 3d wrap around of sky with clouds and the sun (I suspect that it was made in Terragen using the spherical camera or something similar).

So there are two suns lighting the scene. You can make the background visible and you will see the clouds (you can also see them reflected on the ends of the nacelles, or any other shiny surface).

The shadow line will either be due to the Rhino sun or the exr sun but it is odd that it is so distinct b4 I do the view mode toggling and then is very blended or not there after.

To my knowledge there are no other lights in the scene (unless there are some VRay lights or something in some layer that I forgot). Over time I have mucked about with different renderers and gone back to Cycles.

At least in the file you shared with me I cant see any layers.

I took a closer look at the screenshots you shared. On one of the tubes where you have highlighted the oddness:

… this looks like three spot lights in there. Looking at the deck area I think I see remnants of that also just above the panorama window, here marked with green arrow.


If you don’t mind sharing the entire model with me using the same link as before I’ll gladly take a look and see if I can figure out what part of it is causing the light reflections.

Trying to navigate your model while Raytraced is active, selecting parts etc, shows some problems that we’ll have to look into as well (Rendered mode IMO is also slowing signs of selection delay).

I’m uploading now. It’s 1.6 Gb compressed. Could I have saved it using Save Small?

As for issues when in raytraced mode… I find that I have crashes when moving the view while Rhino is updating data onto the graphics card or changing materials too often whilst Rhino is trying to keep up with the changes.

That only happens on my laptop which has a mobile cuadro card. I don’t think that my main PC has those problems.

Should I raise another issue for that?

That is not necessary. I believe the 7.5 service release that hopefully goes out this week will alleviate most of your crashing problems.

Does that have the multiple, different, GPU support?

If so then I will stick all my GPUs in my server and have a rendering session :upside_down_face:

No, not yet.

I am working on fixing multi-device rendering. This week I should be able to install an RTX A5000 as a pair for the RTX A6000, so I can really test any fixes I make there.

Now that’s just showing off :wink:

Well if I’m not rendering then I will do some modelling. Or some Grasshoppering.

Making geometry in Grasshopper takes longer but then you can tweak curves or parameters and regenerate huge chunks of model in no time. I did the saucer and deck two (the glass latticework) in Grasshopper. I use a separate 3dm file to generate geometry and then import it into the rendering file.

By the way, with Rhino 7 I suggest using Rhino Render through the _Render command instead of using _ViewCaptureToFile. Especially in cases where a rerender is required it is better resource wise to do a _Render with no view in Raytraced mode. Especially with your heavy model it’ll be a good thing.

I have tried the 7.5 release. (7.5.21100.3001, 2021-04-10)
Most renders are normal but I saw this, this afternoon, when I opened the file that I sent you.

I had previously selected v33 and raytraced before I exited the program the last time I used it. So Rhino was opened up in v33 with raytraced on.

I saw this

You can see that there are a large number of “overexposed/white” areas.

The area on deck 2 is larger, all the areas that were present on the previous examples are larger.

There are also the streaks on the nacelle (tube) on the right side of the image.

I have seen these streaks before so they have been present before release 7.5.

And I have used raytraced on release 7.5 without these issues.

Note the white, partial, rings on the front and middle areas of the nacelles… I have seen these before on images that I thought were normal (I just thought that they were normal highlights. They still could be.) But maybe this issue is more prevalent than I realized.

I tried to fix by cycling to ghosted then back to raytraced.

I got this.

Cycling again fixed things and the render looked perfect.

That looks weird indeed. I see it every once in a while happening, but not reliably, so it has been hard to pin down and fix.

Until an actual fix is found you’ll have to rely on toggling the viewport, unfortunately :confused:

These two pics show that shadows also go weird when the highlights appear. I don’t know if you have made that connection.

The difference is being the sun off and on respectively.

This happens sometimes, but I have not been able to pinpoint the reason.