Impossible surface?


(Playe Flo) #1

Hello everyone,
I’m an architecture student in France and I got a problem with my Grasshopper.
I’ve tried everything, but I really can’t do a surface threw a few curves.
I have an arborescent structure, that supports curved beams.
The shape of the square is like a quarter of a circle, a bit like a L with a circle between the two lines.
There is one curve that does the contour of the square, and then seven curves : I upload some pictures to help you understand :
5125
So if someone could save my project and help me with this… I’d be so grateful!
Thank you!


#2

Upload the curves.


(Playe Flo) #3

I’ve cooked them on rhino to help you understand, but I’d like to do it on grasshopper…
What do you mean by upload the curves ?
525158


(David Rutten) #4

There is no way to convert these curves into an exact nurbs representation, because they do not represent a quadrilateral structure. You can try Patch, or creating a larger surface using Loft and then trimming using the outer loop curve. But as @RIL said, without the curves themselves, all advice you’ll get will be abstract.


(Amir Soltani) #5

Upload the Rhino file which contains these particular curves.


(Playe Flo) #6

Thank you all for your answers, I upload you the rhino file, thank you for your help ! I’ve put on it the patch of the curves, that does not work. Loft doesn’t work too… Moreover, I need to do it on grasshopper because then I need to add more branches thanks to a grid that I got to add on the surface, in order to have one beam every 1.5 meters…
P3.3dm (3.4 MB)


(Aris Nikolopoulos) #7

surface.gh (3.0 KB)

surface (2).3dm (45 Bytes)
I think the “y” of your two ‘horizontal’ curves that meet at the right of the plan view is what’s causing the problem.
I just got rid of the one (and divided the circumference into two U and two V curves.)
I don’t know if it suits you


(Playe Flo) #8

Thank you for your help, so you think that I can’t put one of the two parallels curves ? (This one on the picture below)test
I’ve got all the branches of my arborescent structure that comes to this, like on this pic :
07
so maybe should I put out this one for the surface and then bring back a beam that fits with the surface ?


(Playe Flo) #9

And I can’t open your rhino file, it says “This document is not a rhino file” …


(Aris Nikolopoulos) #10

surface.3dm (229.6 KB)
sorry, I was in a hurry to leave and I somehow changed the extension of the file

You must understand that your curves have to be separated as a rectangular grid, they need to be like a net. the curves in one direction are the U and in the other direction are the V
kind of like the image below

That’s why I cut your perimetric curve in four, (two U’s -first and last- and two V’s -again first and last)

you can put the line you are talking about, but you have to transform it so that it starts and finishes either on U or V, you cannot start from V and finish in U this is ‘illegal’ You cannot have triangles…
I hope i made you understand.


(Playe Flo) #11

Hi,
Thank you for your help,
I’ve tried to cut my curves as you taught me, by adding too the second curve (the one you deleted), but apparently it doesn’t work. I bring you my rhino file.
Thank you again for your help!
P3.3dm (3.9 MB)


(Playe Flo) #12

It works when I dont’t select all the curves (like you did.)
Maybe is there an other way to do it ? Like without the curves ? I have all the points that creates them


#13

A good alternative, like David Rutten suggested (and he knows!), would be to model your final solution with NURBS surfaces, trying to use the curves that your growth has generated. The triangular surfaces, inevitable here, would then end up as trimmed surfaces.


(Aris Nikolopoulos) #14

I understand this second curve is important for you because you allready made the columns. This file is working, (you can now modify the V curves to better approach the design you have in mind.
surface.gh (7.7 KB)
surface.3dm (325.2 KB)
the circles show where the four side curves meet.


(Playe Flo) #15

Thank you so much for your help, I’ll try this at home tonight and I’ll come back to you!!


(Playe Flo) #16

Thank you for solving my problem !
I’m so grateful! I just have now to create a lot of curves like in this shape that gets threw the actual curves and I got my surface!
Do you think I can create them on grasshopper ? I should keep the middle curve (that we don’t use any more) because as on the picture of last time, I’ve got the columns that passes there.
Thank you again!


(Aris Nikolopoulos) #17

pas de problème! :wink:


(Playe Flo) #18

I’m really sorry to annoy you for so long and after all the help you brought me, but I really don’t arrive to bring it on my grasshopper… I feel really bad!
I never had such a problem with rhino…
It makes 5 or 6 times that I restart the process but it still does not work…


(Playe Flo) #19

I join you the rhino file, I now really can’t see why it’s not working any more…surface.3dm (5.4 MB)
(it’s this one) :


(Aris Nikolopoulos) #20

Man,
you are not paying attention! have a look at the image: