Impossible Rotate bloc object

Hi every one,

a collegue have find a Bug with the rotate 3d objectcommande.

in this file, it is impossible to rotate to 180° the bloc!!! but it is possible whith another value, Why?

Best regards

P1808-MOD_Gousset problème rotation.3dm (88.4 KB)

It seems to work here, I tried Rotate3D using the centers of the hole edges as the axis and typing 180/Enter…

Edit - ahh, didn’t look at the picture close enough, I used your axis and indeed it seems to fail. Will look further.

graet good luck

I think it must be a calculation bug with the block transformation based on the fact you are pretty far from the origin - around 50K units in X and Y and 10K units in Z…

The following all worked:
Exploding the block (becomes an extrusion)
Moving it closer to the origin (even halfway seems to work fine)
@wim , looks a bit buggy to me, can you check it out on your end? (also fails in the V7 WIP)

ok i have move the bloc at the origin and the rotate command run normaly

But this part is on a big building and for the moment, this is the only part with rotate bug :S.

For the moment, i haven’t test the rhino 7 wip.


Thanks for reporting, guys!
I see the same on my end and have created RH-52124.
I see the same issue in Rhino 5 and put this on the list of things to be fixed for Rhino 7.