Importing from Vectorworks (DWGs/DXFs)


(Lukas R) #1

Hey all,
I’ve been trying to import 3D models from Vectorworks 2018 into Rhino 6. The DWG export from Vectorworks has generally been working fine for me, but Rhino imports broken models. I tried with three different Vectorworks files, each shows correctly in eDrawings but imported into Rhino, the geometry is completely broken. See attached screenshots.
The Vectorworks 3DM export creates huge files (500 MB vs 3 MB DWG), takes forever to import/export and results in a very laggy model in Rhino consisting only of polysurfaces, so that’s not really an option either.


Possibly a similar problem like this one: Rhino 6: DWG import from Vectorworks geometry damage


(Pascal Golay) #2

Hi Lukas - can you send one or more of these to us? Any example that shows the problem would be helpful, the smaller the better - it need not be a ‘real’ file.

thanks,

-Pascal


(Lowell Walmsley) #3

What specific version of Rhino are you using?
We have had trouble with the way Vectoworks writes surfaces. I fixed something about missing surfaces from Vectorworks files about 2 weeks ago. I think the fix got in SR6.4


(Lukas R) #4

I am using:
Rhino Version 6 (6.3.18090.471, 31.03.2018) Evaluation, which I downloaded yesterday. When I do an update check it says I am on the current release.
Vectorworks 2018 SP3 R1 (Build 418943) (64-Bit)

As a sample file, I created a 10 by 10 metre rectangle with its bottom left corner on the origin and extruded it by 5 metres.
Vectorworks file: https://www.dropbox.com/s/dtztws2v3gpigfy/Ohne%20Titel1.vwx?dl=0
DWG 2018 file: https://www.dropbox.com/s/e30ga74zekrftvq/Ohne%20Titel1.dwg?dl=0


#5

Rhino doesn’t open Vectorworks .vwx files directly, but the DWG opens fine here with a box of 10m x 10m x 5m (I specified meters as model units in the import dialog).

–Mitch


(Lukas R) #6

Which version are you on? It looks like this when I import it into Rhino:


#7

SR4 RC3 (Release Candidate) (6.4.18107.1041, 17-04-18)

So if it’s a recently fixed bug, and you’re still on SR3, you’ll have to try to get the current release candidate. In Options>Updates and statistics, set the dropdown to Release Candidate. I’m not sure if that setting is available in the Evaluation version, I hope it is.

–Mitch


(Lukas R) #8

Alright, it’s working now that I’m on the Release Candidate Channel. Thanks everyone!