Import from Grasshopper, Export to SolidWorks

Hi,
I need help with import file from Rhino 6 Grasshopper to SolidWorks 2018. I tried to save file as Model 3D Rhino 3*.3dm and *.igs. When I import *.3dm file receives a message that the object has no planes / solids. When I import *.igs file there is no message but nothing is in this file. I have created 3d print cellular like in photo using Grasshopper. Can anybody help me? How do it correctly? Finally I want to use Simulation in SolidWorks.
rhinosceros|690x313
Best Regards, Kacper!

Not sure if this will help, but I think you need to bake your geometry to Rhino, and then you will be able to export to IGES/Parasolid/STEP, all of which are importable to Solidworks… I will recommend using Parasolid as it is the native modeling kernel for Solidworks (I think).

Thank you. Works.

Hi again…
I have one more problem with my model from Rhinoceros. I want to put in my structure to SolidWorks Simulation. My model must be a “solid model”, not a surface. I tried to change surfaces in solid in SolidWorks and in Rhinoceros but it don’t work. In SolidWorks i can only make a rod empty inside. Anybody have an idea? Maybe there is an option in Rhinoceros that i don’t know yet? I upload a ScreenShot of my model in Rhinoceros.
Thank you for help.

Maybe uploading your model would help?

When you import in Solidworks, is it open or a closed surface? If, it is a close surface you can “knit surfaces” in SW and convert it to solid. If it is open you will have to work on your topology to achieve a closed brep either in Rhino or SW.

If you are using Pipe, as in your first post, you can right-click on the ‘E’ (Caps) input and use ‘Flat’ or ‘Round’ instead of the default ‘None’. This will produce “Closed Breps” (solids) instead of “Untrimmed Surface”.

caps

Imported model in SolidWorks has a open surface. I don’t have to work with my topology, because advice from Joseph_Oster work!

I upload a photo how it look like now in SW.
Thank you guys very much again!

And how before

The ‘Round’ ends instead of ‘Flat’ on Pipe might work even better in this case? In GH, however, they would likely cause Solid Union to fail.