Grasshopper polysurface not visible in Solidworks


I have a file created in grasshopper that consists of solids/polysurfaces. They bake into Rhino with no issue. When I attempt to export to solidworks some parts import with no issue, but the outer surfaces do not appear. Here is what I have attempted thus far;

  • file formats of .igs/.step/.3dm (v. 3-5)/.x_t

  • adding additional surfaces to create closed/watertight solid in rhino prior to export

  • flipping surfaces

  • boolean operation into a solid in rhino

Since nothing has worked, I feel the issue may be in the way I have setup the construction in grasshopper? I am stumped, any help would be appreciated!

image (42.4 KB)

Hi -

I tried saving to STEP and then importing that STEP file again into Rhino and didn’t see any issues. I wouldn’t know why SolidWorks has issues with this…

There’s a significant change in the curvature near the flared edges over a very small distance.
I’m guessing that may be the problem.
I cannot get the flared surface into SolidWorks, but if I duplicate the edges, I can get curves into SolidWorks … Curiously some are missing.
I can generate the surface in SolidWorks from the curves as a Boundary Surface and curvature analysis again shows abrupt curvature change over a very small distance.

@wim and @cdordoni -
Thank you for taking the time to look into this issue. @cdordoni I believe you are on to something with the abrupt curvature change.

The continuity of the outer edge is only positional, but the interior throat tangency is controlled by lines connected to a smaller setback circle. I assume at some point the tangency causes too abrupt of a change for SolidWorks. I will test to see if there is a limit at which SolidWorks accepts the surface curvature.

your curves have 3 stacked control points at the marked location, this is probably causing the issues:

1 Like

@Gijs - good catch! I added a rebuild to try and correct this. It does better distribute the points, but does not correct the curvature anomaly that @cdordoni mentions, thus it still does not open in solidworks. I believe I need to look at the BlendCrv and see if there is a better way to construct.


So I have looked into the BlendCrv, but seems OK. Next looked at the Sweep2 used to construct the surface, and tried replacing this command with an EdgeSrf. The outcome was this strange lip. This seems to coincide with the abrupt curvature change the Sweep2 was causing. I am thinking now I need to add another control type curve in the center of each panel?

I tried a number of ways to build these surfaces differently, but all met with some issues and in the end didn’t create the exact surface needed. In a fit of desperation I tried simple rebuild command again as @Gijs suggested, this time it worked. Must have been operator error when I attempted the first time.

Thanks for all the help! (40.2 KB)