Image sampler missing

unhandled
imagesampler

(Doaa Alsharif) #1

Hi All,
I have this GH def that uses an image sampler. Everytime I open the file I get this message:

in both cases (Yes or No), the file opens with the definition but the image sampler is missing.

Why does this happen and how can I avoid it?

preforated screen for office.gh (52.1 KB)

Thank you


(David Rutten) #2

I get the same error message. Presumably the Image Sampler crashes while it is trying to write itself to the file. Does this happen with all image samplers, or only for a specific image file?


(Doaa Alsharif) #3

All gh files with an image sampler.


#4

This has been happening for several years, often reported on the old forum. Makes exchanging code files difficult since the image sampler has to be copy/pasted and wired into the new code to make it work.


(Doaa Alsharif) #5

Are you saying that the image sampler can’t transferable from one file to another, and from one version to another?


(David Rutten) #6

@doaa can you upgrade to Rhino6 and GH1? I think this bug was fixed.


(Doaa Alsharif) #7

I am on Rhino 6.1 and this is the GH version that I have:


(David Rutten) #8

The gh file you uploaded was saved with 0.9.0076, which is GH for Rhino5.


(Doaa Alsharif) #9

So I can’t open old gh files in a newer version?
but, even if i open this file with the older version 0.9.0076 i get the same error.


(David Rutten) #10

No, the problem was that the old version of Grasshopper didn’t correctly save the image sampler. No version of GH can correctly open that file because it is inherently faulty.

Grasshopper files can be opened by both newer and older versions, provided that all components are available on your machine. If the file contains components from a plugin you do not have or components that ship with a newer version of Grasshopper, then the load will (partially) fail.


(Doaa Alsharif) #11

ok got it!
I will test with different files and get back to you.

Thank you David.