Image Sampler in GH of Rhino WIP not working

image
grasshopper

#1

When loading any image, GH will report error:

Any ideas?


#2

Anyone looking at this issue?


(Steve Baer) #3

Have you tried loading an image from a different directory? There may be something about that specific directory that is causing a problem. Just a guess. @DavidRutten may have a better idea, but I believe he is on vacation this week.


#4

Yes, I tried different dictionaries.
No luck.


#5

Loading an image in the sampler seems to work here in latest WIP… --Mitch


(Brian James) #6

Can you post your GH definition and the image texture you’re referencing in the component?


#8

Image_Sampler.gh (17.8 KB)


#9

And there is nothing special with the definition.
Even I just open a new file and drag “image sampler” to the canves, load any image, the component will report cannot gather floating data, and the export info has nothing…


#10

Dunno, your component definitely gives an error here, but pulling a new one from the menu works fine (I don’t have your image) or even using the original but loading a different image… ???

Image_Sampler_M.gh (78.5 KB)

–Mitch


(Brian James) #11

I’m seeing the same as Mitch here. The error indicates that “Impulse-PATTERNS\patterns-scriptographer_2.png” isn’t found within my downloads directory. When you’re testing with other images, are they all out of this directory? I’m not sure how the image data is supposed to be saved in the component so @DavidRutten will have to chime in for that. In a 3dm the image texture data in say a material would be extracted to a new folder in the download directory. In GH maybe it isn’t extracted. In any case, I can replace the image file in your component and I’ll get the error one more time about the impulse patterns folder and then it works fine.


#12

I tried to re-install Rhino and Microsoft .NET C ++ libraries, and everything seems working fine now.

Still don’t know what causes the problem and sorry for wasting your time on this issue.

Thank you.