Image artifacts with ViewCaptureToFile and Scale option

This might be related to ViewCaptureToFile at large scale shows tiling artifacts (FIXED)

When using ViewCaptureToFile with Scale>1, I am getting artifacts in the resulting PNG or JPG images. This manifests in a shaded box, typically in the lower-left corner of the images, that has the dimensions of the un-scaled image.

This is in 7SR16 and arctic display mode and parallel view projection.

Here is an example file with which we can reproduce this reliably on different machines in the office

VCF_Scale2_example.3dm (2.5 MB)

I’m not able to reproduce that using your file and a scale of 1.1.

It appears to be a “tiling” artifact.

What does your Rhino SystemInfo look like?

Hi John,

You’re right. I can’t reproduce the effect with Scale=1.1. The screenshot was taken with Scale=2.0, which I forgot to mention in my post. Apologies for that.

Here is the sysinfo, as requested:

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Commercial, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 12-23-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
- Windows Main Display attached to adapter port #2
Primary OpenGL: NVIDIA Quadro RTX 3000 (NVidia) Memory: 6GB, Driver date: 3-25-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 465.89
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-25-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\UMI\Umi.Energy.rhp “UMI Energy”
C:\UMI\Umi.DistrictEnergy.rhp “Umi DistrictEnergy”
C:\UMI\Umi.Mobility.rhp “UMI Mobility”
C:\UMI\Umi.SiteAnalysis.rhp “UMI Site Analysis”
C:\UMI\Umi.Daylight.rhp “Umi Daylighting”
C:\UMI\Umi.Bia.rhp “Umi Harvest”
C:\UMI\Umi.Lifecycle.rhp “UMI Lifecycle”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\axelj\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Thank you

Hi Axel -

I’m not seeing that here with these settings:

I suppose the next step would be to disable the plug-ins that do not ship with Rhino.

Hi Wim,

thank you for looking into this.

I’ve uninstalled the UMI plug-in, disabled Clipper and PanelingTools. Could not reproduce the artifacts. So all good.

Even with re-enabling Clipper and PT, I was unable to get the artifact again. UMI is gone for good – I only played around with it recently, but couldn’t get it to work. None of my colleagues had UMI installed on their systems (only Clipper and PT), but were able to re-create the observed artifact.

To make matters even more complicated: it only shows up in some views, but not others. I am not sure how to progress from here. Obviously, you guys need to be able to trigger this ‘bug’ (if this is indeed what we are looking at), but I can’t find a surefire way of triggering it.