I'm getting an error login message when I try to open the app - can't use Rhino!

Here’s a couple screen shots

Are you able to go to your Rhino account and log in?

If you mean this one yes. Let me try again

no the same problem occurs.

I replied in the forum. But I’m not sure if that’s the account you mean.

No, I’m talking about your account at accounts.rhino3d.com - where your license is kept:

Yes I can login to that

OK, then if it’s still not working after having logged into your Rhino account, I might simply suggest that you close everything and restart your computer… On the Windows side at least, this usually fixes the problem.

I’m on a Mac. But I’ll give it a try…

Still no better.

Hello???

You must of self-isolated or something. Is there anyone that can pick this up please?

Well he’s on Switzerland time…

On Windows sometimes you have to log out and back into your account on rhino3d.com for it to register that you are actually logged in, but I thought that was a Windows-specific thing.

I don’t understand why I’ve to log in to anything! Suppose the internet is down. Is my application now subject to this trouble. I’ve time to do work and instead I’m waiting on some GD tech problem. This is unacceptable.

I also have a commercial license - or did until now when it’s showing as educational. WTF??

Your license is in your Rhino account, it should work for up to about two weeks without an internet connection - from the last time you used Rhino. Every time you run Rhino it tries to log in and see the license and reset the time. If it has trouble logging in it should give you a message in the notifications panel. If you have not used Rhino in two weeks and it can’t manage to log in for some reason, it will not run until it can. I suspect that is the situation you are in now.

If you can access your Rhino account as you said above, you might be able to remove the license from there and install it locally on your machine. I say “might” because something might be stuck somewhere and either it will not let you remove the license from your account or not let you install it locally… In that case only McNeel tech support may be able to help.

I downloaded and reinstalled and I still get the same nonsense. What supposedly happens after 2 weeks? I’ve left message with tech support that declares they’ll get back to me after lunch or whatever, but that aint happened yet. I’ve more than enough technical obstacles these days, I don’t expect such from McNeel and company. I don’t see as this is somehow a professional application. Mayber it’s the change of my license from commerical to educational. That’s a frosty bit more nonesense.

Did you try logging out of your Rhino account and back in?

Where are you seeing that? And no that’s not the reason you haven’t gotten a reply, it’s that you’re asking on a Saturday during a pandemic.

Your Rhino login account is linked to your Google account.
Any chance your computer is logged in using a different Google account?

You need a Rhino login account to get access to the Cloud Zoo floating license tool. This allows you to float your single computer license between multiple computers without being limited to an office LAN.

Your Rhino 6 license is an EDU license. All that means is at the time you purchased your upgrade, you provided EDU proof of status and saved some money. There is no difference in the software or support.

I went to the account and removed the google account associated. Reentered my key locally and it gave the option of one local machine or the cloud. Thanks for the clarification.