Idle process just working once


#1

Hi…,

I have tried the idle process option with _IncrementalSave.

Here it saves after 60 seconds idleness, but after that never again (even if I do nothing in Rhino for minutes).

Any ideas why idle works just once here?

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #2

Hi Michael - sorry, I misread your note before, if you saw my irrelevant initial response… I was thinking of AutoSave, not IncrementalSave. Dale Fugier tells me the idle processor does not run if there is no interaction with Rhino since the last idle process timer ran out.

I think there is no harm done, with this as it is now, is that correct?

-Pascal


#3

Hi Pascal,

hm? After IncrementalSave I work on, then I stop working for minutes, but then it never saves incremental again.

I have here a customer with a sometimes unstable server, so he found nothing in the autosave directory. Damn. He lost Rhino work of three days. I recommended him now the idle option, but it doesn’t seem to save as I would expect it.

Have you another idea? More a lazy solution, where he need not click every now and then on a save button?

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #4

Hi Michael - I would think Save or IncrementalSave in IdleProcessor would do it… but maybe I am still misunderstanding - are you saying that if the user makes some changes and then leaves Rhino alone for the idle processor period and the save occurs, then he interacts with Rhino again, and then leaves it alone again for the idle processor period, it does not save again? If that is the case that is incorrect or unexpected behavior, I would say.

But, if the idle processor time runs out and the save occurs, and the time runs out again, with the user not interacting with Rhino, there is no second save, that is expected, BUT, there is also no lost data, correct, so nothing actually is lost?

Now… what about the Autosave… is the autosave folder on a network? I’d say that is not recommended , by default it is on the local hard drive and it seems to me that is a better idea.

-Pascal


#5

Hi Pascal,

…that is incorrect or unexpected behavior, I would say.

That is my result.

autosave folder on a network?

I don’t know, I send him a link to this discussion, perhaps he jumps in.

Thank you again for all from Munich and have a good start for 2017. Cheers

Michael
www.flexiCAD.com


(Pascal Golay) #6

Hi Michael -
So, here, if I make a change in the model, the idle timer kicks off again and I get another save, but merely changing the view (for example) does not kick off the idle timer. That is not quite what I’d understood, but if yours works the same way it should still be useful in preventing any great loss of work. I’m not sure if IncrementalSave is really any better than just Save as security though.

-Pascal


#7

Hi Pascal,

the idle process option works here not stable. I add boxes to the model, and wait, but nothing happens. Still waiting…

Can a plug-in stop/influence idleness? I have e.g. DATAKIT Exchange and Flamingo nXt installed.

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #8

Hi Michael - OK, that seems clearly wrong - I don’t get that behavior here, so far (you are testing in a file that has been saved normally at least once, correct?). I’ll see what I can find out about plug-ins, I really don’t know, but I’d be surprised if that makes a difference.

-Pascal


#9

Hi Pascal,

yes, I’ve saved the model as 3dm file (or opened an existing 3dm-file) to get no questions, when _IncrementalSave starts. And yes, something is wrong to me.

Thank you for your time

Michael
www.flexiCAD.com


(Pascal Golay) #10

Hi Michael - well, we are getting mixed results - in a new instance of Rhino, everything works as I originally expected - any interaction with Rhino kicks off the timer and I get another save. @dale sees this as well but on his machine the time is incorrect, so far - about double the expected time (we’re testing with say 5 seconds, but I also tested 60 seconds). In your case, there is no save after the first one no matter what you do to Rhino, correct? If you get a chance, can you also test with a very small number for the timer, like 5 or so?

Also, Is your machine busy, other than with Rhino? The event watcher uses a lowest priority thread, so timing may not be precise if the machine is working hard - but it should not stop working altogether of course.

-Pascal


#11

Hi Pascal,

I set it to 60 seconds, and I get the first incremental save after some minutes. But I never get a second incremental save, even after 30 minutes (and adding first some boxes). Of course I work with other programs (internet surfing with web-browsers, but in this time Rhino is sleeping in the taskbar or just open on another screen.

Aha, setting it to 2 seconds gives me now the expected result, I get those bunch of files. Hm?

Cheers

Michael


(Pascal Golay) #12

@dale - what do you think - 60 seconds, no action, 2 seconds works…

-Pascal


(Dale Fugier) #13

@pascal, I get action at 60 seconds…


(Dale Fugier) #14

Something isn’t right here. I’ve added a YouTrack item so I won’t forget to investigate.

https://mcneel.myjetbrains.com/youtrack/issue/RH-37394


(Pascal Golay) #15

@Michael_Meyer, please try the next WIP and see if this behaves better for you - I believe it works as expected now…
thanks,
-Pascal