I don't get emails about PM or @ mentions


(Brian James) #1

but I am set up to receive these in my Discourse preferences. I checked the Spam folder on the gmail account these should be emailed to as well.

@sam @codinghorror
Sam & Jeff,
Do you have any ideas on how to get this feature working?

Thanks,
@BrianJ


#2

Can you verify that these are set correctly on the mcneel domain?

https://meta.discourse.org/t/configure-your-domain-for-discourse-hosted-email/14177


(Brian Gillespie) #3

It works for me, so I doubt this is DKIM related.

If you are constantly logged into DIscourse, you won’t get emails. However, you’ll get notifications (look for little blue numbers next to the speech bubble in the upper right corner of the page).


(Brian Gillespie) #4

Is there anything else I should mention @stevebaer


#5

Regardless, it is a very good idea to double check those DKIM and SPF settings to be sure.


(Brian James) #6

That may be the cause then. Thanks for explaining about the little blue numbers I’ll try and keep an eye on those. I’d personally like to still get emails when logged in if it becomes a possible option.


#7

It is already an option, check your user preferences.


(Brian James) #8

Ahh yes, I see now. Thanks for pointing that out.


(Brian Gillespie) #9

These instructions seem incorrect to me:

If your instance is community.mydomain.com
create discourse._domainkey TXT record

Shouldn’t it be:

create community._domainkey TXT record?

In any event, ours is discourse.mcneel.com. I’ve created a TXT record for _domainkey.discourse.mcneel.com that returns the value above.


(Steve Baer) #10

I’m replying because I got your mention in an email Brian so things seem to be working for me,


#11

The document is correct; the key is so that discourse.org has permission to send via our mailserver on behalf of your domain. From the bit we host which is of course, this URL, discourse.mcneel.com