I can't find the templates I've made

The topic title pretty much sums it up. After carefully creating a workspace I like, I saved it as a template. Later when I tried to use it, it didn’t show up in the splash screen dialogue box. Doesn’t “save as template” automatically place the file in the correct place? Any idea where my templates are going? Which library are they stored in - the user of system?

from the splash screen, make sure you’re viewing templates instead of recents…

or you can go File-> ‘New using template’


the custom template section will be at the top of the list (you may have to scroll up above the default templates)

once you find that, you can right-click on it for the options of setting it to your default (ie- doing File->New will open your custom template) …or, show in finder. (which will take you to the place where they’re stored… that being here:

That’s the issue - nothing I designate as a template is showing up in the template menu. I looked into the applications support folder for them and I find none at all. I’m wondering where the standard templates are being stored.

when you do File-> Save as Template, are you prompted to assign a name to the template?

regarding your question about the default templates location, they’re here:

personally, i’d stay out of there… files placed in .app/contents will be overwritten upon updating the application.

Yeah, I enter a title and save it. Watch:

2015-10-11_09-17-28.mp4 (3.9 MB)

hmm… yeah. i don’t know then.
it’s always worked fine for me.

maybe the ‘save as template’ is expecting the disk to be named Macintosh HD instead of a relative path? (or- that’s the only thing i can gather that’s different between your set up and mine… you’ve renamed your boot disk).

dan or marlin will have to look into this… i imagine they’ll see it tomorrow

Okay, thanks Jeff. I’ve just recently installed the commercial version over the wip I’d been using. Maybe that’s left some remnant associations that are messing the system up.

Any movement on this thing? Anybody?

The template name must be a valid OS X file name, and MM-05/05/10 is not valid filename because it has slashes. I’ll file a bug about checking template names for invalid characters.

Okay, thanks Marlin.