Human UI version 0.8.0.0 will not run in Matrix


#1

I work within Matrix (8 or 9) because I work for a jewelry company and that’s how we catalogue our projects. I also work with Grasshopper and Human and Human UI a lot to develop organizational tools for our shop.

In the midst of a recent project, I decided to upgrade my Human UI to version 0.8.0.0 to see if that helped me avoid an issue. I couldn’t say if it helped, because the instant I tried to load any Grasshopper files that used Human UI, Grasshopper would freeze and need to be shut down through Task Manager. It seems to specifically be the Launch Window component that causes the problem. I do not have any problems when I open files within Grasshopper within regular Rhino, but not in Matrix, which complicates things for me immensely. I’ve uninstalled and gone back to version 0.7.6.0 for now, but I would like to be able to use updated Human UI in the future. Any insight into what went wrong?


(Andrew Heumann) #2

Hi Gwendolyn - what is Matrix?


#3

Matrix is a skin of Rhino that comes with a bunch of premade builders, libraries, and settings specifically aimed at the jewelry manufacturing process. Sometimes it’s more helpful than other times (like this instance), but I’m obligated to work within it as much as possible to allow for compatibility with the rest of my company (or most other jewelry manufacturers that I’ve worked at/heard about, tbh). ¯_(ツ)_/¯


(Andrew Heumann) #4

ah, I see. Unfortunately I have no idea what sort of a conflict would arise from this. Did earlier versions of Human UI ever work in Matrix?


(Andrew Heumann) #5

ah I see you said that it did with 0.7.6.0, sorry.


(Andrew Heumann) #6

One quick thing to try - run GrasshopperDeveloperSettings and toggle the COFF loading setting - sometimes this can help to resolve DLL conflicts, which could be part of the problem


#7

Matrix 9, Human UI 0.8.0.0, COFF=unchecked… Hard freeze, no good.
Matrix 9, Human UI 0.8.0.0, COFF=checked… Hard freeze, no good.


(Andrew Heumann) #8

well, it’s back to the drawing board then. Unfortunately tracking this down may be quite difficult… since I don’t have Matrix I can’t test/debug against it. Are there any Matrix devs on the forum you know of who could answer a few simple questions?


(Steve Baer) #9

@Trav may be able to help here. Mentioning him just in case.


(Travis Serio) #11

@ChrisIARhino this ones for you I believe.


#12

no idea what human ui is, pluin for rhino that uses grasshopper? we don’t do anything with grasshopper so not sure. what does human ui do?


(Travis Serio) #13

It generates UI for Grasshopper. Similar to a Matrix builder panel for the lack of a better explanation.


#14

Last time I looked at Grasshopper it was called explicit history, I’ll try download it and that addon this weekend and see if I can reproduce. If OP Could post step by step on how to test that would help tremendously as like I said, I have no recent experience with grasshopper, why I would also have to download and install it first.


(Andrew Heumann) #15

If it helps from a technical standpoint, the plugin builds a WPF window and relies on several third party libraries like MahApps.Metro, HelixToolkit, XCeed.WPF, and De.TorstenMandelkow.MetroCharts - does Matrix happen to rely on any of these?


#16

GemBoxUI-EXAMPLE.gh (22.5 KB)

  1. Run Windows 10, Matrix 9 (Build 7144), Grasshopper 0.9.76.0, with additional Grasshopper plugins Human and Human UI 0.8.0.0 installed.
  2. Launch Grasshopper and load my attached sample file.
  3. Double-click the toggle button labeled “Switch this on to LAUNCH WINDOW” to change its value to True.
  4. At this point, for me, Grasshopper freezes hard and must be force quit via task manager.

#17

figured I’d try to get it running in just Rhino first, this is what I get following your instructions in just Rhino, and yeah, it freezes and I have to ‘kill’ Rhino after this:


(Andrew Heumann) #18

from the screenshot it looks like you haven’t loaded the Human plug-in - make sure you have this one installed as well (separate from Human UI) Human.gha (413.5 KB)
still, that shouldn’t have resulted in a crash, so I’m a bit baffled.


#19

Any update on this, @ChrisIARhino? Did you get the Human plugin installed so you could test my sample to replicate the error?


#20

I was able to reproduce, at this point not sure what if anything can be done on our end. Not sure why worked before and not now. Looks like it hangs making window, once you close matrix it finally shows the window.