Launch Window error in Rhino.Inside.Revit

I’m getting an error message from Launch Window component in Rhino.Inside.Revit Grasshopper.

It works fine outside Revit both Rhino WIP and 6 versions.
I checked Human UI versions, and files seem to be the latest version.

Can someone let me know any possible causes of this issue?
Thank you!

I don’t have Revit, so I’m unable to test this. I suspect it’s some kind of DLL conflict with Revit. What Revit version are you using? I know @scottd was able to run human UI in revit 2019.2

Thank you, Andrew. I tested in Revit 2019.2, and it has the same error. I saw a person outside my company using Human UI succesfully in RiR with Revit 2020, but everyone using RiR in my company experiences the same issue.

I am pretty sure this is related to the adjustment Kike has made to try and improve performance. It has disabled some updating. He is working on the next build to turn this on and off globally so in this case it updates properly, but also can be disabled when wanting to rock and roll in Revit. I will check with him on this.

Kike said: Some users were complaining on performance about this and I disabled it temporary. Next release will include it back as well as a way to pause and unpause it manually. We are also exploring ways to partially disable parts of a definition.

1 Like

I spent some time to find the cause this week, and I could finally find what caused the issue. It seems that Biomorpher has conflict with Human UI. After I deleted Biomorpher folder from Grasshopper Libraries, I could remove the error.

What’s interesting is that there is no conflict between Human UI and Biomorpher outside Revit.

@johnharding I’m also adding you to this thread to see if you could resolve the conflict.

Hi there. I’ve installed the latest version of HumanUI (not something I’ve installed before) and Biomorpher v0.7. and things seem to be running fine (albeit outside of Revit**):

Just checking, both HumanUI and Biomorpher use .NET Framework 4.5. However they do share some common libraries (Helixtoolkit and Mahapps), and I’m not sure how Grasshopper prioritises loading of these, according to version no., etc. I’m guessing that’s the source of the issue. Checking the version numbers:

System.Windows.Interactivity: 3.0.40218.0
MahApps.Metro: 1.4.1

System.Windows.Interactivity: 3.0.40218.0
MahApps.Metro: 1.5.0
HelixToolkit: 2015.1.715.0

I know I have struggled to get MahApps 1.5 to work for Biomorpher, hence sticking with 1.4 for the time being, but that could be causing the issue. On the flip side, I notice HumanUI uses an old version of HelixToolkit, but as the error is flagged when simply opening a window I would suspect it is the Mahapps version that causes the issue. However, please try installing the latest version of Biomorpher and let me know how you get on because it does seem to work fine for me. If you’re still having issues, I can maybe try again to get things working for the latest Mahapps release.



** I can’t bring myself to install Revit I’m afraid to test it out, apologies!

@johnharding Thank you for looking into the issue and detailed explanation. I tried the latest Biomorpher version, but it didn’t resolve the conflict with the launch window component of Human UI inside Revit. Outside Revit, no conflict even with a previous version of Biomorpher. I guess RiR somehow affects prioritizing loading of common libraries between two plugins?

1 Like


Just to pick up on this, I have created a new Pre-Release which now references the same MahApps version (1.5.0) as the latest HumanUI as well as specifically named HelixToolkit libraries to hopefully address any conflicts with plug-ins such as Octopus.

Be interesting to know if this solves the Revit issues…