How to save a logo as a .PNG with a transparent background (not black)

I’m trying to save a logo that is just text objects with a solid black hatch and a transparent background BUT when I render it and try to save it using the_viewcapturetofile command with “transparent background” checked, I get a black logo on solid black background. When I uncheck “transparent background”, I get the grey background. I can change the color of the logo but I always get the black ground and dont know how to resolve the issue. This is the first time i’ve tried this and cant figure out how to accomplish the task. I’ve read through numerous posts but cant figure it out. can someone please outline the process for me.

If you use cycles check SHOW RGBA CHANNEL (RGB with Alpha)

Thank you for the response. I apologize but I’m new to this and dont quite understand what that means.

take a screenshot of the render window

this is the render window with text objects with solid black hatching along with the _viewcapturewindow dialog settings:

The resulting .jpg file shows the logo in a black background. If I change the color of the text objects and rerun the command, the resulting file show the logo in the new color against a black background. The problem is that I cant use the .jpg file with a black background as a image file for my vendor. I dont know how to save the file such that it is transparent except for the text objects.

This is a view capture not render
you can export the text as SVG and open it with Photoshop

Hi Gary,

Jpegs can’t have a transparent background (which is why you get solid black). Change the file type to .PNG when saving the view capture from Rhino and that will have a transparent background.