How to render png images with a transparent background?

unhandled

#1

Hi, I’m new to Rhino.
I’m trying to render some .png images without a background on the new Rhino for Mac
When I preview them in the viewport set to render mode they look ok, but when I render them they came out with a white background.
I’m using the PictureFrame command with the alpha transparency option.
How can I render png images without a background?

Thank you, L


(Brian James) #2

Open the Material editor from the Render drop down menu and add the same png texture to the transparency channel of the pictureframe material. Post the png too if you can, it would be good to use it as a bug/feature request.


#3

Thank you Brian,
still not working.
I´m attaching some samples so see what I mean


(Brian James) #4

Thanks… my test didn’t have black in it but this looks like a bug to me. I’ll file something now for the developers to look into. In the meantime, I made you a transparency map to use with this texture map. I also made a png version with an alpha channel in PS but it didn’t work any better than yours.

@andy might have more input here too.



#5

Thanks…
I will do this for now


#6

Hello Brian,
I’m having an issue with images not showing alpha channel or otherwise. I’ve already managed to use picture frame to place images but now any further attempts give a gray field with an error message ‘image not found’. Can you take a look at this. Perhaps I’ve mis set an import setting?

Images.zip (2.4 MB)

Top2.3dm 2.zip (170.9 KB)


(Brian James) #7

I see this here as well for the Top image and filed it as http://mcneel.myjetbrains.com/youtrack/issue/MR-2474

I did find that using Export As from Photoshop to save new copies of your png files allowed them to be imported but the alpha is shown as white… this will be a separate bug report. http://mcneel.myjetbrains.com/youtrack/issue/MR-2475

One other thing I noticed was that the front image name in your 3dm file wasn’t using the same name for the image file “front” instead of “frnt”… I don’t think it’s connected to the issue I reported but thought I’d mention it.


#8

Okay, Thanks much. I’ll continue just using jpegs for the time being.

However, having briefly had transparency available for the ref images I’m keen to have it again:relaxed:


#9

I’m a bit late to the party, but I believe I figured this out - at least for what I was trying to achieve. In Photoshop save the image with its Alpha channel as a BMP since it retains the Alpha channel. In the Material editor use that for the Color. Then create the inverse, along with a corresponding Alpha channel and save that as BMP as well. Use this image as the Transparency in Rhino.


(Warren) #10

Hi, Sorry this is my first post. I’m using Rhino for Mac 5, and I have this problem too, I’m creating .pngs in photoshop but can’t get the transparency to work when I render. I can’t follow Justin’s method. In PS CS you can’t output a BMP with Alpha Channel so… is there any easy way around it.