Import a PNG transparent background picture

When I place a png with a transparent background into Rhino 5 with pictureframe command
It comes with a white background, even though in Photoshop it is transparent.
Is it possible to import a PNG, or JPG, or PDF to Rhino 5 still keeping the transparent background ?
Thanks
Rachel

Yes. Once you start the PictureFrame command, and you have chosen your image, but BEFORE you set it in the Rhino window, you will see some command line options. One of them will be AlphaTransparency, set that to Yes. Suggest you always set EmbedBitmap to yes as well so the image is saved with the file.

JPEG’s do not support alpha channels so you will not get transparency with a jpg. PNG works fine.

HTH, --Mitch

1 Like

thank you very much !!

Where is this option? I have Rhino 5, but I don’t see the option “alphatransparency”…

1 Like

When you call the command you are asked to find a file. In that dialog box, select a file and click Open. In your command line you will now see the options. If you have clicked once in the viewport to set the first corner, you will only have two options left on the command line so you need to set that option before clicking.

It’s not there I swear :s

It should be here… I used PictureFrame and Rhino 5 SR12


Here’s a sample png with an alpha channel as well to test

Another possibility is to set the transparency afterwards:

I believe that ‘Trans’ slider will affect the entire image, not just the alpha channel.

You are right of course.
The transparency slider, set to 1%, helps to get the same effect after placing the image without setting the flag.
Just in that case.

I’m having a problem where even when I set the alpha flag to yes, it still renders a white background. Yes, it is a PNG file, so I don’t know what the issue is.

Does the PNG itself have transparency in the alpha channel? Setting the flag in Rhino only tells it to use the alpha channel that is already in the image, it does not alter the image itself.

–Mitch

I would like to know the answer to this too please.
Can one import an image into Rhino 6 and make the background transparent ?
When printing the Transparent background shows up as black!!!

All:

Currently stumped on this issue. I create a .png file in Photoshop Elements 10 which according to PSE has a transparent background which I’ll try to upload into this post. When I use the Picture command in Rhino 7 to paste it into my drawing, I get the white background. So I go to materials panel and the alpha channel box is checked. I can vary the transparency but that’s for the whole image. Checking around on the web it seems like png does not support alpha channel (!?). But what do I know? Surely there has to be a straightforward procedure to import only line art but I am not the best finder of things.

Best hopes,

Hilary Smith
Pacific Northwest

I had to do a little experimentation to figure out why your image isn’t working. Open it in Photoshop - in Image>Mode, it is an “Indexed Color” file format. Change that to RGB and re-save the file - then try it in Rhino.

It’s not really beautiful though, looks like this here against my dark background:

I had also stumbled on the white mask solution that Pascal suggested below, looks like the result is about the same.

Hi Hillary - It looks like you can use a white color mask with this image -

but I am not yet sure why the alpha is being ignored - it is a 256 color /8 bit image, it looks like it was once a black/white bitmap, I do not know if that comes into play, still poking.

@mrhsmith8 - try this one - rgb + alpha

-Pascal

@pascal - how did you get rid of the white/gray outline on yours?

image

I added an alpha from the grayscale version and then changed it all to rgb (in Affinity) and exported. As opened in Affinity, there is no sign of an alpha that I could see, but I am not a wizard with that somewhat opaque software…

It is pure bitmap as far as I can see
image
no gray.

-Pascal

Pascal Golay,

BINGO! I’ve got the transparent line art I wanted with the white mask. Much gratitude and thanks!

Hilary

Hello pascal, Can I set this ‘Use color mask’ by RhinoCommon?
I’m using Rhino7 and 7.7.21160.5000 version of RhinoCommon.