How to open .tmp file


#1

Looks like a file I was working in yesterday did not save properly. However, the .tmp file is still here. I tried to open this file using Rhino - and I can see the preview image at the start screen - but Rhino says the file type is not supported. Is there any way to use this file to recover my work?


(Chris Kuether ) #2

Have you tried simply renaming the file to *.3dm? That’s what I’d do first…


(Pascal Golay) #3

Hi Jenya-
Did it appear to save? Was there a crash or anything abnormal during the save? Is there a corresponding Autosave file in the AutoSave folder (Options > Files will show you where that is). Is there a 3dmbak file in the original file’s folder?

-Pascal


#4

Changing the file extension to .3dm worked!


(John Brock) #5

Something must have interrupted the Rhino save mechanism.
When editing a file, a TMP file is created for the session. When you save if it was an existing file, the old 3dmbak file is deleted, the 3dm file is renamed 3dmbak, and the tmp file is renamed 3dm. This way there is always a copy of the file on the disk.
The most likely scenario I can think of would be to close Rhino and quickly force a hibernation by closing the lid on a laptop while the file rename dance is underway.
If that sounds familiar, don’t do it.
Save your file and close Rhino.
Wait 30 seconds or so before closing the lid.
I personally go one step farther and close Window. The lid on my laptop does close until the screen is black.
The only exception to that is if I’ve only been using an Internet browser or email and don’t care if the session is saved or lost.


#6

I had this happening on my workstation yesterday, for the first time ever.
A .3dm file was gone and a .3dm_tmp was in it’s place. So thanks for making a fool-proof solution!


#7

Just a small update / heads up, this just happened to my brother today too, and then both him and I have gotten this thoday when hitting Ctrl-S (save):
image

Obviously the file was not opened as read only, so some conflict is going on.
And then when hitting OK this pops up:

image

So now the file appears for Rhino to be gone (since .3dm_tmp files are hidden for Rhino).

We are not working on the same project, so that’s not what’s causing it, but both are using the same Dropbox area (as we allways do) so this is a strange coincidence. Either Dropbox has altered something, Windows is updating some settings, or Rhino has updated something (we updated to latest SR a few days ago)

Both computeres were shut down yesterday.

We’ll reboot and then keep our eyes on it and see if it is a one-time-only happening, or if it is a new trend :wink:


(John Brock) #8

Since it’s a monitored folder (Dropbox), I suspect Rhino was blocked temporarily when trying to do it’s file dance involving creating, deleting, and renaming files.