How to Add Rhino Items to “New” Context Menu?

Hi

I created a blank template file (Rhino.3dm) in folder C:\Windows\ShellNew\Rhino.3dm
Also I changed the registry keys

[HKEY_CLASSES_ROOT.3dm]
@=“Rhino 3-D Model”

[HKEY_CLASSES_ROOT.3dm\ShellNew]
“Filename”=“Rhino.3dm”
@=“Rhino 3-D Model”

[HKEY_CLASSES_ROOT\Rhino5x64.Document]
@=“Rhino 3-D Model”

But a new Items does not appear in the context menu Windows

This is right

and example for linked file in registry in Win7x86 (that works here)

Stringkey = FileName
Value = Rhino.3dm (Your rhino file)

Last step -> logoff and logon, or restart pc

Hi Eddi!
and thanks so muсh :slight_smile:
But by trial and errors I found some other way.
I used the path to my templates in Rhino.
<img src="https://aws1.discourse-cdn.com/mcneel/uploads/default/original/3X/0/3/03dbbdc3e93bb95942629ab1aa6727bfb2df2214.jpg" width="400" height="308">

1.3dm for the convenience of a name for the new file
"FriendlyTypeName"="1"

But the main error (While it worked in Rhino 4)
[HKEY_CLASSES_ROOT\Rhino 3d model] Now in Rhino5 this section in the registry is not

[HKEY_CLASSES_ROOT.3dm]
@=“Rhino 3-D Model”

I replaced to

[HKEY_CLASSES_ROOT.3dm]
@=“Rhino5x64.Document

[HKEY_CLASSES_ROOT\.3dm]
@="Rhino5x64.Document"
"Content Type"="application/3dm"

[HKEY_CLASSES_ROOT\.3dm\OpenWithProgids]
"Rhino5x64.Document"=""
@="Rhino 3-D Model"

[HKEY_CLASSES_ROOT\.3dm\ShellNew]
"FileName"="C:\\Users\\leex\\AppData\\Roaming\\McNeel\\Rhinoceros\\5.0\\Localization\\en-US\\Template Files\\Small Objects - Millimeters.3dm"

and

Rhino5x64.Document
[HKEY_CLASSES_ROOT\Rhino5x64.Document]
@=“Rhino 3-D Model”
“FriendlyTypeName”=“1”

[HKEY_CLASSES_ROOT\Rhino5x64.Document\DefaultIcon]
@="\"C:\\Program Files\\Rhinoceros 5 (64-bit)\\System\\Rhino.exe\",1"

[HKEY_CLASSES_ROOT\Rhino5x64.Document\shell]
@="open"

[HKEY_CLASSES_ROOT\Rhino5x64.Document\shell\open]
@="Open with Rhinoceros 5 (64-bit)"
"FriendlyAppName"="Rhinoceros 5 (64-bit)"

[HKEY_CLASSES_ROOT\Rhino5x64.Document\shell\open\command]
@="\"C:\\Program Files\\Rhinoceros 5 (64-bit)\\System\\Rhino.exe\" \"%1\""