How do I get round control points?

I know in previous versions we could issue a ‘testtogglepoints’ command, and presto, our points would toggle from round to square (per session).

But now the command only yields “Unknown command”.

I’ve looked under View -> Display Modes -> _____ -> Objects -> Points, but only see “Solid Square” and “Square with white center” listed.

Is there some secret sauce I’m missing? Or has the idea of round control points vanished? Here are my video card settings:

Aha, the command is


For anyone who is interested. (Some stray old newsgroups posts led me to the wrong command)


ha. nice. i watched a rhino video a while ago which had round points in it… i just figured the option wasn’t available on mac yet and it seemed too small of a thing to bug @marlin about…
but this command does it and it does work on mac.

Not working for me with Rhino OSX (470)

I have tried toggleroundpoints and all variations

Got it, needed the caps.Cool

If memory serves, I think the reason this feature was left as a test command was that not enough GPUs could anti-alias the control points. So behavior for the display option would vary too much. I agree it looks nice though. Maybe @jeff can come up with a more ubiquitous method in Rhino 6.

It’d be nice to see it in the display mode options where ‘points’ are listed. Perhaps a option like ‘Round Solid (beta)’ would be good.

Or a checkbox in the OpenGL settings called ‘Enable Round Control Points (beta)’.

(mac beta)

i realize testToggleRoundPoints isn’t an official command etc.
but should it remember it’s on between sessions?

(as in- run the command, quit rhino, relaunch rhino, points are still round)

i actually have a shortcut for this command which i (manually) use when launching rhino but just curious if the setting should stick automatically?

Hi Jeff- I put this in my startup commands… Options > General.


Yes, like pascal said it’s better to put in that place.

1 Like

I’m on mac.
no startup commands yet

(unless I’m blind… which is a real possibility. :wink: )

[edit]__ but I was more curious if it were a mac thing causing it to not stick… but I see now that’s how it works for everybody… so I’ll just keep doing what I’ve been doing until mac rhino gets user startup options.
thanks fellas

hmm there is another solution for this…

purchase a customizable mouse

i recommend this one :wink:

heh… thanks. I use mx performance mice but I have those buttons for things of a little more importance or more often used :wink:

idk, I was just going through my alias list doing some spring cleaning with the macros that haven’t stuck with me. was just curious if the round point one was unnecessary. I’ll keep it around for now.

Thank you so much for :grinning:


And why such a strange switch? :face_with_raised_eyebrow: