Why do are my points square when ROUND is selected in Rhino Options?

Hi, I’ve been working with GH lately, and somehow at some point, my points changed from round to square. Any idea how I may have done this or how to fix it? In Rhino Options, my ‘Control point style’ is set to ‘Round with white center’ for all Views, but my points in Rhino (with or without GH open) keep on defaulting to square. It’s minor but frustrating!!

Hi Kate - are you certain the active display mode there is Ghosted? Just making sure…


Yes the viewport is set to Ghosted - and actually the ‘Control point style’ of all my display modes is the same. Just now I opened Rhino Options again and opened the Objects submenu ‘Points’ which I didn’t know was there - and then I thought maybe this is the issue because the ‘PointCloud style’ was set to ‘Solid square’. However for every Display mode, I changed the ‘PointCloud style’ to ‘Round with white center’ and selected OK, and my points (even new ones added) are still coming up square.

Please run SystemInfo and paste the results here. I want to make sure you are operating at a high enough OpenGL level to support round points

Rhino 7 SR8 2021-7-15 (Rhino 7, 7.8.21196.05001, Git hash:master @ 45c1fd6dc85c7c1cce8c0bbe6f3e16481ae9abfa)
License type: Commercial, build 2021-07-15
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [72% battery remaining] ~238 minutes left

Non-hybrid graphics configuration.
Primary display and OpenGL: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
NVIDIA Quadro P620 (NVidia) Memory: 4GB, Driver date: 11-20-2020 (M-D-Y).
> Integrated accelerated graphics device (shares primary device ports)
- This device is not being used

No graphics device is being used. Either an error occurred on startup, or certain devices have been disabled.
See below for any possible configuration changes that may help resolve this issue.

  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 0.0 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 11-20-2020
Driver Version:
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Kate - are those points in the Rhino file, or are they being drawn by Grasshopper?


@pascal it’s OpenGL. See the notes in the systeminfo report above. @jeff do you have any recommendations on getting the nvidia GPU to be used.

My guess is it’s a performance setting thing.
She’s on battery power and my guess is Windows is set for battery saver or balanced which disables the Nvidia GPU.

Control Panel > Power Options
Change to High performance for everything including battery operation.

I just plugged in the laptop (it was at 68%) charge. @pascal The big square points are from GH and the little square points I just created in Rhino. I am going to call Dell support and ask them how to enable the Nvidia GPU. Thank you.

Presumably, then, you once had the Nvidia card working. You probably accidentally (or deliberately without realizing the unintended consequences) changed something in the video setup.

Dell will surely help you straighten it out.

One way would be to disable the Intel GPU using the DeviceManager… That will force Windows to always use the NVidia (discrete) GPU.


I spoke to a technician at Dell who told me NVidia should automatically launch when using Rhino. She didn’t know why it wasn’t kicking in. Then we looked at the fix @John_Brock proposed below and everything looked fine.

Control Panel > Power Options
Change to High performance for everything including battery operation.

But while we were on that screen, the one change the Dell technician made (for no particular reason) was to switch it from ‘Dell’ to ‘Balanced’ and when I opened up Rhino and ran SystemInfo, we could see that it was picking up NVidia…and I was able to make circle points!!

Thank you all for leading me in the right direction!!

Good. I am curious if you leave it at Balanced, and are running on batteries, if the Nvidia card is not used.
If that’s the case, at least you will know why display tools quit working and your points go square again.