Both the Rhino.Options.General.AutomaticPointsOn and the Rhino.Options.General.PointsOnObjectSelect keys read True in the Settings Editor but it doesn’t look like that matters in the latest WIP. Points are off when a curve gets selected.

On the latest WIP, automatic points on works again.

But it looks like something changed in the way points are rendered to screen. For one, TestToggleRoundPoints no longer works. Also, my display mode has point size set to 4 (style square with white center) but they are tiny on screen. Setting the size to 6 doesn’t make a difference.

I was now able to test the WIP on an older PC that I’ve just updated to run Win 10 and to my surprise see that round points and bigger sizes thereof works OK on that one. @stevebaer, anyone, any clues as to why this is not working on my main PC? The points are tiny and this is driving me crazy (-crazier?).

Could you send a me a screenshot of the points and one showing your setting? I just want to make sure I set up things exactly the same as you.

Hi Steve,
here comes (also attaching an ini for the exported display mode)…
Note that the RoundPoints command is toggled to ON.

2015-09-11 display settings - wrmd.ini (10.6 KB)

@stevebaer, just to let you know - in the 2015-09-29 WIP that I just installed now, points are round and big again.

This should actually be the default for everyone now. I also removed the TestToggleRoundPoints command since the round option should now be available on everyone’s computer. This is something you can set in the display mode options.