How can I reference a polyline in ArchiCAD from Grasshopper, macOS Sierra 10.2.6, Rhino 5.4.2, Archicad 21

The simplest of examples ‘creating a parametric tower’ will not work properly because I can’t convert the referenced ArchiCAD polyline to a Grasshopper curve… If I deconstruct the ArchiCAD polyline I can convert the result to a Grasshopper curve, but then I can not make a slab of it (outline curve is self-intersecting)…
Is this a known bug Mac-bug (I know it works on PC), and is there a workaround?


Please read it.

I’ll illustrate.
In the User Guide it looks like this:

But on my Mac it looks like this:

If I deconstruct the reference, it is accepted, kind of…

But I can’t make anything, like a slab, out of it - it’s self-intersecting…

Is this a known Mac-bug, and is there a workaround? - or should I just ditch my Mac and by a PC?


It worked for me. What version of AC are you using ?

Wow, that’s good news, but I see that you also have to deconstruct the Archicad polyline… or have you tried to go directly from Archicad polyline to Grasshopper curve?
I’m using Archicad 21, build 6013 NOR FULL.

I’m using the 22 version for this trial and have the same results. Maybe it’s a bug or it’s a changing in the last version which has not been updated in the doc.

Any word on a fix to this issue? I’m using AC 21 build 7000 and rhino 5 on windows.