How can I export a Pen Plus view of only visible surfaces as vector paths?

I’ve been looking for a way to streamline my workflow by being able to export a Pen Plus view as vector paths for editing in Adobe Illustrator. I’ve used the ‘Make2d’ command as I had seen suggested in other posts, but if I export as a PDF the ‘vector’ option exports all the lines in the design - whereas ‘raster’ exports only the visible surfaces which is what I want. The Illustrator Live Trace tool isn’t precise enough to convert the raster PDF into editable paths (I’ve tried adjusting the default line width, higher resolution, larger paper sizes etc…) and nothing seems to work.

Does anyone have any suggestions on how to export a Pen Plus view of on only visible surfaces as vector paths? I’ve attached screen shots of the results of both raster and vector PDF export options for reference, any help on this would be extremely appreciated.


my workflow: ViewCaptureToFile
the scale as needed - vectorize by middle line

Hi -

Exporting as vector or as raster shouldn’t make a difference for Make2D geometry.

Thanks for the reply - in this case it’s not a matter of the geometry, it’s the difference in output between ‘vector’ and ‘raster’ PDF options. The raster option exports the correct view (only visible surfaces). The vector option exports vector paths, but of the entire wireframe, as I tried to show in the attachment in my original post.

Ideally I’d like to export the Pen Plus view of only the visible surfaces as vector paths, instead of having to trace them with the pen tool manually in Illustrator.

Hi @heatwavevisual
I don’t understand your problems with the Make2D command… It sounds as if you either A) didn’t have “Hidden lines” unchecked, or B) didn’t export the Make2D result (which are separate curves on a separate layer) correctly.

After Make2D, locate the resulting curves in the top viewport and export those as a *.ai file, open in Illustrator - I’ve done that hundreds of times and should work.
HTH, Jakob

1 Like

It worked! Thank you very much, I had no idea about the Make2d elements being on a separate layer. This is a huge help, I really appreciate it.

1 Like