History button won't stay push

I push the History button and as soon as I make a change on the design it goes off. I didn’t have any issue with it until last 2 updates.
Any one has a solution for that?

Not on a Mac at the moment - but that is how it works if you don’t have Always Record History turned on. You can turn that on by right-clicking on the History button.

Hi @daharishahar-

Sorry for the delayed reply. I cannot reproduce this on my end on macOS Mojave using Rhino 5.5.2. Can you please provide some additional information. Navigate to Rhinoceros > About Rhinoceros > More info… > Copy to clipboard and paste the contents in here?

Also, can you please take a screenshot of the top of your Rhinoceros window where the history button is located?


Hi Dan.

I installed the latest update, and made this video for you so you can see what the problem is,

Thank you for the reply,

Hi Dharishahar-

Sorry, I don’t see a video. Perhaps you forgot to attach it?



This is strange, I see the video in the sent email. I tried again buy putting the video in a zip file

Please try to add the video when visiting Discourse and not by sending eMail.

Problem solved, even though I downloaded the new version I kept opening the old version and I just realised it

Thank you