Hidden line style fails on curves

Choosing hidden line style, 0.5 Print preview. on

My pecked line ceases to be so on curves.

file also attached

ItemForMetalTwists.3dm (73.4 KB)


It works fine on non-straight curves (try it on your circles) but on very short segments it can be unreliable based on the scale of the dashes. The curve needs to be at least twice as long as the pattern length (in your case the pattern length is 4). If you modify the linetype of your “hidden” linetype to 0.5, the dashes will show up.

I don’t know what to suggest here, this has been a classic problem with linetypes and short curves.


Hi, looking at the dash length there was enough length for a gap to occur if not two, visually anyway.

look at that shallow curve for example.

Time it was fixed I hope.


As I said, it needs to be at least “line+space+line+space” long. Two lines and two spaces.

Hi Steve - run LinetypeDisplay - there are some settings there that should help.


Wow… That’s a new one for me. Thanks! --M

Likewise :smile:
pattern by segment = no fixed it !


If the default linetype doesn’t suit your geometry, you can always create custom linetypes - here’s an example with smaller gaps which may work for you.

ps. that’s with ‘LinetypeDisplay’ using ‘PatternBySegment=Yes’ in this case.