Heron 0.4 ImportLAZ shows no points or errors, opens in CloudCompare fine


Hello, I just started using Heron for Grasshopper today so this might be an easy fix and I’m just ignorant.

I downloaded a .laz point cloud file off of opentopography.org and wanted to bring it into Rhino for further use. When I point ImportLAZ to the file, it doesn’t give me any errors and gives the right Info and SRS outputs but no points. I have tried .laz and .las files, tried other datasets from OT and still have this same issue. I have opened each of the files in CloudCompare with no issues.

I have searched several forums trying to troubleshoot this and have not found anything. I would upload some of my test .laz files but they are too large. The behavior is consistent regardless of file used so I am not sure how much that would help.

Thank you

Hi @user463
Can you point me to which file you downloaded from opentopography.org? ImportLAZ uses the laszip.net library to process the point clouds and I know there are some limitations based on the format of the laz file. However, a quick test of a Red Rocks point cloud produces the following:


I didn’t even think of this - I can link my OT results page. Here is one of the data sets I used.

But its seemingly, the problem has fixed itself. I downloaded a Red Rocks point cloud, I think even the exact same one. Heron grabbed all the points no problem. I went back and tried one of the point clouds from yesterday again and Heron again imported all the points. No clue why- same files, no system or configuration changes. I was even able to clean the point cloud up in CloudCompare and import that without any issues. The only thing is now it doesn’t report SRS information even though opentopography does include that info. But that isn’t a big deal for my needs.

Thank you for replying and trying to help. I’m sorry I cannot provide more information about what my problem yesterday could have been.

Good to hear! Let me know if you come across any more issues.